]> git.pld-linux.org Git - SPECS.git/blob - vigra.spec
SPECS updated Wed 1 May 10:14:00 CEST 2024
[SPECS.git] / vigra.spec
1 # TODO: lemon support, WITH_LEMON
2 Summary:        Generic Programming for Computer Vision
3 Summary(pl.UTF-8):      Ogólne programowanie obrazu komputerowego
4 Name:           vigra
5 Version:        1.11.1
6 Release:        14
7 License:        MIT
8 Group:          Libraries
9 #Source0Download: http://ukoethe.github.io/vigra/#download
10 Source0:        https://github.com/ukoethe/vigra/releases/download/Version-1-11-1/%{name}-%{version}-src.tar.gz
11 # Source0-md5:  e72faf9fb82fa71fa63ba064bb63b703
12 Patch0:         python-install.patch
13 Patch1:         boost-python.patch
14 # https://src.fedoraproject.org/rpms/vigra/raw/master/f/81958d302494e137f98a8b1d7869841532f90388.patch
15 Patch2:         %{name}-multi_convolution.patch
16 # https://src.fedoraproject.org/rpms/vigra/raw/rawhide/f/vigra-openexr3.patch
17 Patch3:         %{name}-openexr3.patch
18 URL:            http://ukoethe.github.io/vigra/
19 BuildRequires:  OpenEXR-devel
20 BuildRequires:  boost-python-devel >= 1.40.0
21 BuildRequires:  cmake >= 2.6.0
22 BuildRequires:  doxygen
23 BuildRequires:  fftw3-single-devel
24 BuildRequires:  hdf5-devel >= 1.8
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libpng-devel >= 2:1.4.0
27 BuildRequires:  libstdc++-devel >= 6:4.4
28 BuildRequires:  libtiff-devel
29 BuildRequires:  pkgconfig
30 BuildRequires:  python >= 1:2.7
31 BuildRequires:  python-devel >= 1:2.7
32 BuildRequires:  python-numpy-devel
33 BuildRequires:  rpmbuild(macros) >= 1.586
34 BuildRequires:  sed >= 4.0
35 BuildRequires:  sphinx-pdg
36 BuildRequires:  zlib-devel
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 VIGRA stands for "Vision with Generic Algorithms". It's a novel
41 computer vision library that puts its main emphasize on customizable
42 algorithms and data structures. By using template techniques similar
43 to those in the C++ Standard Template Library, you can easily adapt
44 any VIGRA component to the needs of your application, without thereby
45 giving up execution speed.
46
47 %description -l pl.UTF-8
48 VIGRA to skrót od "Vision with Generic Algorithms" (widok z ogólnymi
49 algorytmami). Jest to nowa biblioteka do obrazu komputerowego kładąca
50 główny nacisk na algorytmy i struktury danych z możliwością
51 dostosowania do własnych potrzeb. Poprzez użycie technik szablonów
52 podobnych do tych w standardowej bibliotece szablonów C++ (STL) można
53 łatwo zaadaptować dowolny komponent VIGRA do potrzeb własnej aplikacji
54 bez poświęcania szybkości wykonywania.
55
56 %package devel
57 Summary:        Header files for vigra library
58 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki vigra
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       fftw3-single-devel
62 Requires:       hdf5-devel >= 1.8
63 Requires:       libjpeg-devel
64 Requires:       libpng-devel >= 2:1.4.0
65 Requires:       libstdc++-devel
66 Requires:       libtiff-devel
67 Obsoletes:      vigra-static < 1.7
68
69 %description devel
70 Header files needed to compile programs with vigra.
71
72 %description devel -l pl.UTF-8
73 Pliki nagłówkowe potrzebne do budowania programów używających
74 biblioteki vigra.
75
76 %package -n python-vigra
77 Summary:        VIGRA Python bindings
78 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki VIGRA
79 Group:          Libraries/Python
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       python-numpy
82 Suggests:       python-PyQt4
83
84 %description -n python-vigra
85 VIGRA Python bindings.
86
87 %description -n python-vigra -l pl.UTF-8
88 Wiązania Pythona do biblioteki VIGRA.
89
90 %package -n python-vigra-devel
91 Summary:        Development file for VIGRA Python bindings
92 Summary(pl.UTF-8):      Plik programistyczny wiązań Pythona do biblioteki VIGRA
93 Group:          Development/Libraries
94 Requires:       cmake
95 Requires:       python-vigra = %{version}-%{release}
96
97 %description -n python-vigra-devel
98 Development (cmake config) file for VIGRA Python bindings.
99
100 %description -n python-vigra-devel -l pl.UTF-8
101 Plik programistyczny (konfiguracja cmake'a) dla wiązań Pythona do
102 biblioteki VIGRA.
103
104 %package doc
105 Summary:        Development documentation for vigra library
106 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki vigra
107 Group:          Documentation
108
109 %description doc
110 Development documentation for vigra library.
111
112 %description doc -l pl.UTF-8
113 Dokumentacja programisty do biblioteki vigra.
114
115 %prep
116 %setup -q
117 %patch0 -p1
118 %patch1 -p1
119 %patch2 -p1
120 %patch3 -p1
121
122 %{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' config/vigra-config.in
123
124 %build
125 install -d build
126 cd build
127 %cmake .. \
128         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
129         -DWITH_BOOST_GRAPH=ON \
130         -DWITH_OPENEXR=ON
131
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} -C build install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/vigra
141 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vigra
142 %py_postclean
143
144 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/vigra*
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files
153 %defattr(644,root,root,755)
154 %doc LICENSE.txt README.md
155 %attr(755,root,root) %{_libdir}/libvigraimpex.so.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libvigraimpex.so.11
157
158 %files devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_bindir}/vigra-config
161 %attr(755,root,root) %{_libdir}/libvigraimpex.so
162 %{_includedir}/vigra
163 %dir %{_libdir}/vigra
164 %{_libdir}/vigra/VigraConfig*.cmake
165 %{_libdir}/vigra/vigra-targets*.cmake
166
167 %files -n python-vigra
168 %defattr(644,root,root,755)
169 %dir %{py_sitedir}/vigra
170 %attr(755,root,root) %{py_sitedir}/vigra/*.so
171 %{py_sitedir}/vigra/*.py[co]
172 %dir %{py_sitedir}/vigra/pyqt
173 %{py_sitedir}/vigra/pyqt/*.py[co]
174
175 %files -n python-vigra-devel
176 %defattr(644,root,root,755)
177 %dir %{_libdir}/vigranumpy
178 %{_libdir}/vigranumpy/VigranumpyConfig.cmake
179
180 %files doc
181 %defattr(644,root,root,755)
182 %doc doc/{vigra,vigranumpy}
This page took 0.933175 seconds and 4 git commands to generate.