]> git.pld-linux.org Git - SPECS.git/blob - varnish-libvmod-header.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / varnish-libvmod-header.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define vmod    header
6 Summary:        A header-modification VMOD for Varnish
7 Name:           varnish-libvmod-%{vmod}
8 Version:        0.3
9 Release:        2
10 License:        BSD
11 Group:          Daemons
12 Source0:        https://github.com/varnish/libvmod-header/archive/3.0/%{vmod}-%{version}.tar.gz
13 # Source0-md5:  49fef160237d9f4b90b27ef0d11e2552
14 URL:            https://github.com/varnish/libvmod-header
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libtool
18 BuildRequires:  python-docutils
19 BuildRequires:  varnish-source
20 %{?with_tests:BuildRequires:    varnish}
21 %requires_eq_to varnish varnish-source
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         vmoddir %(pkg-config --variable=vmoddir varnishapi || echo ERROR)
25
26 %description
27 Varnish Module (vmod) for manipulation of duplicated headers (for
28 instance multiple Set-Cookie headers).
29
30 %prep
31 %setup -qc
32 mv libvmod-%{vmod}-*/* .
33
34 %build
35 %{__aclocal} -I m4
36 %{__libtoolize}
37 %{__autoheader}
38 %{__automake}
39 %{__autoconf}
40
41 VARNISHSRC=$(pkg-config --variable=srcdir varnishapi)
42 %configure \
43         VARNISHSRC=$VARNISHSRC \
44         VMODDIR=%{vmoddir} \
45         --disable-static
46
47 %{__make}
48 %{?with_tests:%{__make} check}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %{__rm} $RPM_BUILD_ROOT%{_libdir}/varnish/vmods/libvmod_%{vmod}.la
56 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libvmod-%{vmod}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README.rst LICENSE
64 %attr(755,root,root) %{vmoddir}/libvmod_%{vmod}.so
65 %{_mandir}/man3/vmod_%{vmod}.3*
This page took 0.717678 seconds and 3 git commands to generate.