]> git.pld-linux.org Git - SPECS.git/blob - ucidr.spec
SPECS updated Sat 31 Jul 20:27:02 CEST 2021
[SPECS.git] / ucidr.spec
1 # TODO:
2 # - fix makefile to use CC and *FLAGS
3 # - fix desc - it's just a library, not a program
4 Summary:        A small static library for IPv4 CIDR operations
5 Name:           ucidr
6 Version:        1.1
7 Release:        1
8 License:        LGPL
9 Group:          Libraries
10 Source0:        http://unixservice.com/source/libs/%{name}-%{version}.tar.gz
11 # Source0-md5:  7f19628e97ec2d212bc66cbd7b3f4fdc
12 Patch0:         %{name}-include.patch
13 URL:            http://openisp.net/ucidr
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 The ucidr program provides functions for determining if a given IPv4
18 is in a given IPv4 CIDR specified block among other basic CIDR
19 operations.
20
21 Current version provides these functions:
22
23 unsigned ExpandCIDR4(const char *cCIDR4, char *cIPs[]); unsigned
24 uIpv4InCIDR4(const char *cIPv4, const char *cCIDR4); unsigned
25 uInCIDR4Format(const char *cCIDR4,unsigned *uIPv4,unsigned
26 - *uCIDR4Mask); unsigned uInIpv4Format(const char *cIPv4,unsigned
27 - *uIPv4); unsigned uGetNumIPs(char *cCIDR4); unsigned
28   uGetNumNets(char
29 - *cCIDR4);
30
31 %prep
32 %setup -q
33 %patch0 -p1
34
35 %build
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} install \
42         DESTDIR=$RPM_BUILD_ROOT \
43         libdir=%{_libdir} \
44         includedir=%{_includedir}
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc README LICENSE
52 %{_libdir}/openisp/libucidr.a
53 %{_includedir}/openisp/ucidr.h
This page took 0.445722 seconds and 3 git commands to generate.