]> git.pld-linux.org Git - SPECS.git/blob - tvision.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / tvision.spec
1 Summary:        Unix port of Borland TurboVision library
2 Summary(pl.UTF-8):      Uniksowa wersja biblioteki TurboVision Borlanda
3 Name:           tvision
4 Version:        0.8
5 Release:        4
6 License:        Borland, some modifications are BSD-like licensed (generally free)
7 Group:          Libraries
8 Source0:        ftp://sunsite.unc.edu/pub/Linux/devel/lang/c++/%{name}-%{version}.tar.gz
9 # Source0-md5:  7f99404877bb45b2510d43065cbefe6c
10 Patch0:         %{name}-info.patch
11 Patch1:         %{name}-am_fixes.patch
12 Patch2:         %{name}-endian.h.patch
13 URL:            http://www.sigala.it/sergio/tvision/
14 BuildRequires:  gpm-devel
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  ncurses-devel
17 BuildRequires:  texinfo
18 Requires(post,postun):  /sbin/ldconfig
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Turbo Vision (or TV, for short) is a library that provides an
23 application framework. With TV you can write a beautiful
24 object-oriented character-mode user interface in a short time.
25
26 TV is available in C++ and Pascal and is a product of Borland
27 International. It was developed to run on MS-DOS systems, but today it
28 is available for many other platforms (ported by independent
29 programmers).
30
31 This port is based on the Borland 2.0 version with fixes.
32
33 %description -l pl.UTF-8
34 Uniksowa wersja biblioteki TurboVision 2.0 Borlanda. TurboVision jest
35 obiektową biblioteką do okienkowych interfejsów użytkownika w trybie
36 tekstowym.
37
38 %package devel
39 Summary:        tvision header files
40 Summary(pl.UTF-8):      Pliki nagłówkowe tvision
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 tvision header files.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe tvision.
49
50 %package static
51 Summary:        Static tvision libraries
52 Summary(pl.UTF-8):      Biblioteki statyczne tvision
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static tvision libraries.
58
59 %description static -l pl.UTF-8
60 Biblioteki statyczne tvision.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65 %patch1 -p1
66 %patch2 -p1
67
68 %build
69 CXXFLAGS="-I/usr/include/ncurses -fno-exceptions -fno-rtti -fno-implicit-templates"
70 %configure
71
72 sed 's|<sys/time.h>|<time.h>|' demo/puzzle.cc > demo/puzzle.cc.$$ && mv -f demo/puzzle.cc.$$ demo/puzzle.cc
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT{%{_infodir},%{_examplesdir}/%{name}}
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 install doc/tvision.info $RPM_BUILD_ROOT%{_infodir}
83
84 # some cleaning
85 %{__make} -C tutorial   mostlyclean
86 %{__make} -C demo       mostlyclean
87 rm -f demo/Makefile*
88 rm -f tutorial/Makefile*
89 rm -f doc/{*.info,*.texi,*.tex,*.sed,*.kdoc,Makefile*}
90
91 # let's create simple Makefile ("\$" to prevent from macro expansion)
92 cat >tutorial/Makefile <<EOF
93 CPPFLAGS = -g
94 LDFLAGS = -lncurses -lgpm -ltvision
95
96 SOURCES := \$(wildcard *.cc)
97 PROGS   := \$(patsubst %.cc,%,\$(SOURCES))
98
99 all: \$(PROGS)
100 EOF
101
102 cp -a demo tutorial $RPM_BUILD_ROOT%{_examplesdir}/%{name}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post
108 /sbin/ldconfig
109 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
110
111 %postun
112 /sbin/ldconfig
113 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
114
115 %files
116 %defattr(644,root,root,755)
117 %doc doc ChangeLog README TODO Announce COPYRIGHT
118 %attr(755,root,root) %{_libdir}/lib*.so.*.*
119 %{_infodir}/*.info*
120
121 %files devel
122 %defattr(644,root,root,755)
123 %doc doc/*
124 %{_includedir}/*
125 %attr(755,root,root) %{_libdir}/lib*.so
126 %{_libdir}/lib*.la
127 %{_examplesdir}/%{name}
128
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/lib*.a
This page took 0.11212 seconds and 3 git commands to generate.