]> git.pld-linux.org Git - SPECS.git/blob - tracer.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / tracer.spec
1 Summary:        Finds outdated running applications in your system
2 Name:           tracer
3 Version:        0.7.5
4 Release:        1
5 License:        GPL v2+
6 Source0:        https://github.com/FrostyX/tracer/archive/%{name}-%{version}-1/tracer-%{version}.tar.gz
7 # Source0-md5:  6f3e8bba2a918f570ea6eb44db0aae09
8 URL:            http://tracer-package.com/
9 BuildRequires:  asciidoc
10 BuildRequires:  gettext
11 BuildRequires:  python3-dbus
12 BuildRequires:  python3-devel
13 BuildRequires:  python3-psutil
14 BuildRequires:  python3-pytest
15 BuildRequires:  python3-rpm
16 BuildRequires:  python3-six
17 BuildRequires:  sphinx-pdg
18 Requires:       python3-%{name} = %{version}-%{release}
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Tracer determines which applications use outdated files and prints
24 them. For special kind of applications such as services or daemons, it
25 suggests a standard command to restart it. Detecting whether file is
26 outdated or not is based on a simple idea. If application has loaded
27 in memory any version of a file which is provided by any package
28 updated since system was booted up, tracer consider this application
29 as outdated.
30
31 %package -n python3-%{name}
32 Summary:        Finds outdated running applications in your system
33 Requires:       python3-dbus
34 Requires:       python3-lxml
35 Requires:       python3-psutil
36 Requires:       python3-rpm
37 Requires:       python3-setuptools
38 Requires:       python3-six
39 Suggests:       python3-argcomplete
40
41 %description -n python3-%{name}
42 Tracer determines which applications use outdated files and prints
43 them. For special kind of applications such as services or daemons, it
44 suggests a standard command to restart it. Detecting whether file is
45 outdated or not is based on a simple idea. If application has loaded
46 in memory any version of a file which is provided by any package
47 updated since system was booted up, tracer consider this application
48 as outdated.
49
50 %prep
51 %setup -q -n %{name}-%{name}-%{version}-1
52
53 %build
54 %py3_build
55
56 %{__make} man
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT{%{_mandir}/man8,%{_datadir}/%{name}}
61
62 %py3_install
63
64 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/data
65 cp -a data/*.xml $RPM_BUILD_ROOT%{_datadir}/%{name}
66
67 cp -p doc/build/man/%{name}.8 $RPM_BUILD_ROOT%{_mandir}/man8/%{name}.8
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc README.md
75 %attr(755,root,root) %{_bindir}/%{name}
76 %{_mandir}/man8/%{name}.8*
77 %{_datadir}/%{name}
78
79 %files -n python3-%{name}
80 %defattr(644,root,root,755)
81 %{py3_sitescriptdir}/%{name}
82 %{py3_sitescriptdir}/tracer-*-py*.egg-info
This page took 0.236389 seconds and 3 git commands to generate.