]> git.pld-linux.org Git - SPECS.git/blob - trac-plugin-ticketdelete.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / trac-plugin-ticketdelete.spec
1 %define         trac_ver        0.10
2 Summary:        Ticket and Ticket Change Deletion Plugin
3 Name:           trac-plugin-ticketdelete
4 Version:        0
5 Release:        2
6 License:        BSD-like
7 Group:          Applications/WWW
8 # Source0Download:      http://trac-hacks.org/changeset/latest/ticketdeleteplugin?old_path=/&filename=ticketdeleteplugin&format=zip
9 Source0:        ticketdeleteplugin.zip
10 # Source0-md5:  5ea5299648bae63f2ac85c2b0af0fe81
11 URL:            http://trac-hacks.org/wiki/TicketDeletePlugin
12 BuildRequires:  python-devel
13 BuildRequires:  python-modules
14 BuildRequires:  python-setuptools
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  unzip
17 Requires:       trac >= %{trac_ver}
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This is a small plugin to allow deleting tickets from within Trac.
23 Though I don't advocate this as a method of dealing with tickets very
24 often, it is a commonly requested feature, and it is needed on rare
25 occasions (generally dealing with spam).
26
27 It also supports deleting individual changes, including comments.
28
29 %prep
30 %setup -q -n ticketdeleteplugin
31
32 %build
33 cd %{trac_ver}
34 %{__python} setup.py build
35 %{__python} setup.py egg_info
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 cd %{trac_ver}
40 %{__python} setup.py install \
41         --single-version-externally-managed \
42         --optimize 2 \
43         --root=$RPM_BUILD_ROOT
44
45 %py_postclean
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post
51 if [ "$1" = "1" ]; then
52         %banner -e %{name} <<-'EOF'
53         Don't forget to enable ticketdelete in conf/trac.ini:
54
55         [components]
56         ticketdelete.* = enabled
57 EOF
58 #' - vim
59 fi
60
61 %files
62 %defattr(644,root,root,755)
63 %{py_sitescriptdir}/ticketdelete
64 %{py_sitescriptdir}/TracTicketDelete-*.egg-info
This page took 0.03914 seconds and 3 git commands to generate.