]> git.pld-linux.org Git - SPECS.git/blob - trac-plugin-componentdependency.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / trac-plugin-componentdependency.spec
1 %define         trac_ver        0.11
2 %define         plugin          componentdependency
3 Summary:        Allows a component to state dependencies on other plugins
4 Name:           trac-plugin-%{plugin}
5 Version:        0.1
6 Release:        0.6
7 License:        GPL
8 Group:          Applications/WWW
9 Source0:        http://trac-hacks.org/changeset/latest/componentdependencyplugin?old_path=/&filename=%{plugin}-%{version}&format=zip#/%{plugin}-%{version}.zip
10 # Source0-md5:  3330fdc7e1f7f48037089f0a81485fa1
11 URL:            http://trac-hacks.org/wiki/ComponentDependencyPlugin
12 BuildRequires:  python-devel
13 BuildRequires:  python-modules
14 BuildRequires:  python-setuptools
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  unzip
17 Requires:       trac >= %{trac_ver}
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 ComponentDependencyPlugin allows a Component to state a dependency on
23 another Component, via the IRequireComponents interface from
24 componentdependencies.interface.
25
26 %prep
27 %setup -qc
28 mv %{plugin}plugin/%{trac_ver}/* .
29
30 # do not autoload this
31 mv componentdependencies/test.py .
32 sed -i -e '/from test import/d' componentdependencies/__init__.py
33
34 %build
35 %{__python} setup.py build
36 %{__python} setup.py egg_info
37
38 ver=$(awk '$1 == "Version:" {print $2}' *.egg-info/PKG-INFO)
39 test "$ver" = %{version}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 %{__python} setup.py install \
44         --single-version-externally-managed \
45         --optimize 2 \
46         --root=$RPM_BUILD_ROOT
47
48 %py_postclean
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 # NOTE: no post registration needed, plugin not used directly
54
55 %files
56 %defattr(644,root,root,755)
57 %{py_sitescriptdir}/componentdependencies
58 %{py_sitescriptdir}/*-*.egg-info
This page took 0.379876 seconds and 3 git commands to generate.