]> git.pld-linux.org Git - SPECS.git/blob - trac-plugin-accountldap.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / trac-plugin-accountldap.spec
1 %define         trac_ver        0.12
2 %define         plugin          accountldap
3 Summary:        AccountLdap Plugin for Trac
4 Name:           trac-plugin-%{plugin}
5 Version:        0.32
6 Release:        0.2
7 License:        LGPL
8 Group:          Applications/WWW
9 Source0:        http://trac-hacks.org/changeset/latest/accountldapplugin?old_path=/&filename=accountldapplugin&format=zip#/%{plugin}.zip
10 # Source0-md5:  2258bc33b77b648ed7463bff12876364
11 URL:            http://trac-hacks.org/wiki/AccountLdapPlugin
12 BuildRequires:  python-devel
13 Requires:       python-ldap
14 Requires:       trac >= %{trac_ver}
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Allows you to change your password defined in LDAP. Also moved the
20 basic properties of LDAP (user and mail) to the corresponding
21 properties in Trac.
22
23 %prep
24 %setup -q -n %{plugin}plugin
25 mv %{trac_ver}/* .
26
27 %build
28 %{__python} setup.py build
29 %{__python} setup.py egg_info
30
31 ver=$(awk '$1 == "Version:" {print $2}' *.egg-info/PKG-INFO)
32 test "$ver" = %{version}
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 %{__python} setup.py install \
37         --single-version-externally-managed \
38         --optimize 2 \
39         --root=$RPM_BUILD_ROOT
40
41 %py_postclean
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %post
47 # XXX: try to figure out from .egg-info / __init__py at build time
48 #trac-enableplugin "%{plugin}.Trac%{plugin}Module"
49
50 %files
51 %defattr(644,root,root,755)
52 %{py_sitescriptdir}/%{plugin}
53 %{py_sitescriptdir}/*-*.egg-info
This page took 0.169863 seconds and 3 git commands to generate.