]> git.pld-linux.org Git - SPECS.git/blob - tpop3d.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / tpop3d.spec
1 #
2 # Conditional build:
3 %bcond_without  authother       # without auth other support
4 %bcond_without  mysql           # without MySQL support
5 %bcond_without  ldap            # without LDAP support
6 %bcond_without  perl            # without perl support
7 %bcond_without  pam             # without pam support
8 %bcond_without  pgsql           # without PostgreSQL support
9 %bcond_without  ssl             # without ssl support
10 %bcond_without  whoson          # without WHOSON protocol support
11 %bcond_without  gdbm            # without gdbm auth db
12 %bcond_without  snide           # without snide server responses
13 %bcond_with     skipgetpwcheck  # with getpwuid returned struct check ommited (see patch for details)
14 #
15 Summary:        POP3 server
16 Summary(pl.UTF-8):      Serwer POP3
17 Name:           tpop3d
18 Version:        1.5.5
19 Release:        25
20 License:        GPL
21 Group:          Networking/Daemons/POP3
22 Source0:        http://download.savannah.nongnu.org/releases/tpop3d/%{name}-%{version}.tar.gz
23 # Source0-md5:  febe9ca46b575fcf99fd410caff98f47
24 Source1:        %{name}.pamd
25 Source2:        %{name}.init
26 Source3:        %{name}.conf
27 Source4:        %{name}.sysconfig
28 Patch1:         %{name}-pam-vdomain.patch
29 Patch2:         %{name}-sql-getpwuid-optional.patch
30 Patch3:         %{name}-lib.patch
31 Patch4:         %{name}-ssl-chain.patch
32 Patch5:         %{name}-bug-33413.patch
33 URL:            https://savannah.nongnu.org/projects/tpop3d
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 %{?with_gdbm:BuildRequires:     gdbm-devel}
37 %{?with_libevent:BuildRequires: libevent-devel}
38 %{?with_mysql:BuildRequires:    mysql-devel}
39 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
40 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
41 %{?with_pam:BuildRequires:              pam-devel}
42 %{?with_pgsql:BuildRequires:    postgresql-devel}
43 BuildRequires:  rpmbuild(macros) >= 1.268
44 %{?with_whoson:BuildRequires:   whoson-devel}
45 Requires(post,preun):   /sbin/chkconfig
46 Requires:       pam >= 0.79.0
47 Requires:       rc-scripts
48 %if %{with perl}
49 BuildRequires:  perl-devel
50 %endif
51 Provides:       pop3daemon
52 Obsoletes:      courier-imap-pop3
53 Obsoletes:      imap-pop
54 Obsoletes:      imap-pop3
55 Obsoletes:      pop3daemon
56 Obsoletes:      qpopper
57 Obsoletes:      qpopper6
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 tpop3d is yet-another-pop3-server. The intention has been to write a
62 server which is fast, extensible, and secure. `Extensible' is used
63 specifically in the context of new authentication mechanisms and
64 mailbox formats. Presently the distribution supports the following
65 authentication mechanisms:
66 - auth_pam - uses Pluggable Authentication Modules
67 - auth_passwd - /etc/passwd (and optionally /etc/shadow)
68 - auth_mysql - a vmail-sql style MySQL database; see
69   http://www.ex-parrot.com/~chris/vmail-sql/
70 - auth_pgsql - uses PostgreSQL database
71 - auth_other - an external program
72 - auth_perl - embedded perl subroutines
73
74 The latter four options provide virtual domain support; the first two
75 are designed to authenticate local (Unix) users.
76
77 The following mailbox formats are supported:
78 - bsd - for BSD (`Unix') mailspools
79 - maildir - Qmail-style maildirs
80 - empty - null driver
81
82 tpop3d implements an optional metadata caching scheme for BSD
83 mailspools, which offers improved performance in cases where many
84 users leave large numbers of messages on the server between sessions.
85
86 %description -l pl.UTF-8
87 tpop3d to jeszcze-jeden-serwer-pop3. Intencją było napisanie serwera,
88 który jest szybki, rozszerzalny i bezpieczny. `Rozszerzalny' jest tu
89 użyte w kontekście formatów skrzynek. Obecnie pakiet dystrybucyjny
90 wspiera następujące mechanizmy autentykacji:
91
92 - auth_pam - używa Wymiennych Modułów Autentykacji (PAM)
93 - auth_passwd - /etc/passwd (i opcjonalnie /etc/shadow)
94 - auth_mysql - baza MySQL w stylu vmail-sql ; obejrzyj
95   http://www.ex-parrot.com/~chris/vmail-sql/
96 - auth_pgsql - baza PostgreSQL
97 - auth_other - zewnętrzny program
98 - auth_perl - zakorzenione podprogramy Perla
99
100 Ostatnie cztery opcje pozwalają wspierać wirtualne domeny; pierwsze
101 dwie zaś są stworzone by autentykować lokalnych (uniksowych)
102 użytkowników.
103
104 Wspierane są następujące formaty skrzynek:
105 - bsd - dla kolejkowych skrzynek w stylu BSD (`Unix')
106 - maildir - format maildir znany z Qmail
107 - empty - pusty sterownik
108
109 tpop3d implementuje opcjonalne zapamiętywanie (caching) meta-danych
110 dla skrzynek BSD, które znacznie poprawia wydajność w przypadku, gdy
111 wielu użytkowników zostawia dużą liczbę wiadomości na serwerze
112 pomiędzy sesjami.
113
114 %prep
115 %setup -q
116 %patch1 -p1
117 %if %{with skipgetpwcheck}
118 %patch2 -p0
119 %endif
120 %patch3 -p1
121 %patch4 -p1
122 %patch5 -p1
123
124 %build
125 %{__aclocal}
126 %{__autoconf}
127 %{__autoheader}
128 %{__automake}
129 %configure \
130         --enable-mbox-bsd-save-indices \
131         --with-mailspool-directory=/var/mail \
132         --enable-shadow-passwords \
133 %{!?with_pam:   --disable-auth-pam} \
134 %{?with_ldap:   --enable-auth-ldap} \
135 %{?with_mysql:  --enable-auth-mysql} \
136 %{?with_whoson: --enable-whoson} \
137 %{?with_perl:   --enable-auth-perl} \
138 %{?with_pgsql:  --enable-auth-pgsql} \
139 %{?with_gdbm:   --enable-gdbm} \
140 %{?with_authother:      --enable-auth-other} \
141         --enable-mbox-maildir \
142 %{?with_ssl:    --enable-tls} \
143 %{!?with_snide: --disable-snide-comments} \
144         --enable-auth-flatfile
145
146 %{__make}
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 install -d $RPM_BUILD_ROOT{/etc/{pam.d,security,rc.d/init.d,sysconfig},%{_sysconfdir}}
151
152 %{__make} install \
153         DESTDIR=$RPM_BUILD_ROOT
154
155 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
156 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
157 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
158 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
159
160 touch $RPM_BUILD_ROOT/etc/security/blacklist.pop3
161
162 %clean
163 rm -rf $RPM_BUILD_ROOT
164
165 %post
166 /sbin/chkconfig --add %{name}
167 %service %{name} restart "%{name} daemon"
168
169 %preun
170 if [ "$1" = "0" ]; then
171         %service %{name} stop
172         /sbin/chkconfig --del %{name}
173 fi
174
175 %files
176 %defattr(644,root,root,755)
177 %doc README* TPOP3D-AuthDriver scripts FAQ CHANGES CREDITS TODO PORTABILITY
178 %{?with_pam:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/%{name}}
179 %{?with_pam:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.pop3}
180 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
181 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/tpop3d.conf
182 %attr(754,root,root) /etc/rc.d/init.d/%{name}
183 %attr(755,root,root) %{_sbindir}/*
184 %{_mandir}/man*/*
This page took 0.333842 seconds and 3 git commands to generate.