]> git.pld-linux.org Git - SPECS.git/blob - tora.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / tora.spec
1 #
2 # Conditional build:
3 %bcond_with     oracle          # build with oracle support
4 %bcond_with     instantclient   # build oracle support with oracle-instantclient
5
6 Summary:        A graphical toolkit for database developers and administrators
7 Summary(pl.UTF-8):      Zestaw graficznych narzędzi dla programistów i administratorów baz danych
8 Name:           tora
9 Version:        2.1.3
10 Release:        10
11 License:        GPL v2
12 Group:          Applications/Databases/Interfaces
13 Source0:        http://downloads.sourceforge.net/tora/%{name}-%{version}.tar.gz
14 # Source0-md5:  ea4a75a9daeaf58492413e3f7fe40293
15 Source1:        %{name}.desktop
16 Patch0:         %{name}-postgresql.patch
17 Patch1:         %{name}-gcc.patch
18 Patch2:         %{name}-build.patch
19 Patch3:         gethostname.patch
20 Patch4:         qscintilla.patch
21 URL:            http://tora.sourceforge.net/
22 BuildRequires:  QtCore-devel
23 BuildRequires:  QtGui-devel
24 BuildRequires:  QtNetwork-devel
25 BuildRequires:  QtSql-devel
26 BuildRequires:  QtXml-devel
27 BuildRequires:  cppunit-devel
28 %{?with_instantclient:BuildRequires:    oracle-instantclient-devel}
29 BuildRequires:  pcre-devel
30 BuildRequires:  postgresql-devel
31 BuildRequires:  qscintilla2-qt4-devel
32 BuildRequires:  qt4-build
33 BuildRequires:  qt4-linguist
34 BuildRequires:  texinfo
35 BuildRequires:  xorg-lib-libICE-devel
36 Suggests:       QtSql-pgsql
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %if %{with oracle}
40 # ORACLE_HOME is required for oracle
41 %define _preserve_env %_preserve_env_base ORACLE_HOME
42 %endif
43
44 %description
45 TOra features a schema browser, SQL worksheet, PL/SQL editor and
46 debugger, storage manager, rollback segment monitor, instance manager,
47 and SQL output viewer. Via qt3 it can access PostgreSQL and MySQL
48 directly. Any other database systems can be accessed via ODBC.
49
50 %description -l pl.UTF-8
51 TOra zawiera przeglądarkę schematów, arkusz roboczy SQL, edytor i
52 debugger PL/SQL, zarządcę danych, monitor segmentów wycofań, zarządcę
53 instancji i przeglądarkę wyjścia SQL. Poprzez qt3 może współpracować
54 bezpośrednio z bazami PostgreSQL i MySQL. Inne systemy baz danych mogą
55 być obsługiwane poprzez ODBC.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60 %patch1 -p1
61 %patch2 -p1
62 %patch3 -p1
63 %patch4 -p1
64
65 rm -f src/moc_*
66
67 %build
68 %{__libtoolize}
69 %{__aclocal} -I config/m4
70 %{__autoconf}
71 %{__automake}
72 %configure \
73         --libdir=%{_datadir}/%{name} \
74         --with-qt-libraries=%{_libdir} \
75 %if %{with oracle}
76         %if %{with instantclient}
77         --with-instant-client \
78         --with-oracle-includes=%{_includedir}/oracle/client \
79         --with-oracle-libraries=%{_libdir} \
80         %endif
81         --with-oracle
82 %else
83         --without-oracle
84 %endif
85
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
95 cp -p src/icons/tora.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
96 cp -a src/templates $RPM_BUILD_ROOT%{_datadir}/%{name}
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/postshell
102 -/usr/sbin/fix-info-dir -c %{_infodir}
103
104 %postun -p /sbin/postshell
105 -/usr/sbin/fix-info-dir -c %{_infodir}
106
107 %files
108 %defattr(644,root,root,755)
109 %doc BUGS NEWS README TODO
110 %attr(755,root,root) %{_bindir}/*
111 %dir %{_datadir}/%{name}
112 %{_datadir}/%{name}/help
113 %{_datadir}/%{name}/templates
114 %{_datadir}/%{name}/*.qm
115 %{_desktopdir}/*.desktop
116 %{_pixmapsdir}/*.xpm
117 %{_infodir}/tora*
This page took 1.24968 seconds and 3 git commands to generate.