]> git.pld-linux.org Git - SPECS.git/blob - tinycc.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / tinycc.spec
1 # TODO: Do not strip the executable.
2 %define         pre     pre2
3 Summary:        Tiny C Compiler
4 Summary(pl.UTF-8):      Mały kompilator C
5 Name:           tinycc
6 Version:        1.0.0
7 Release:        0.%{pre}.1
8 License:        GPL v2
9 Group:          Development/Languages
10 Source0:        http://www.landley.net/code/tinycc/downloads/%{name}-%{version}-%{pre}.tar.bz2
11 # Source0-md5:  c985f07371e5da24c24889826956671a
12 #Patch0:                %{name}-DESTDIR.patch
13 ExclusiveArch:  %{ix86}
14 URL:            http://www.landley.net/code/tinycc/
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16 %define         tinyccdir       %{_prefix}/lib/tinycc
17
18 %description
19 Tiny C Compiler - C Scripting Everywhere - The Smallest ANSI C
20 compiler. This is a fork of the original tcc released under terms
21 of GPL v2.
22
23 %description -l pl.UTF-8
24 Mały kompilator C - Wszędzie skrypty w C - Najmniejszy kompilator ANSI
25 C. To jest "fork" oryginalnego tcc wydany na licencji GPL v2.
26
27 %prep
28 %setup -q -n %{name}-%{version}-%{pre}
29
30 %build
31 CC="%{__cc}" \
32 CFLAGS="%{rpmcflags}" \
33 HOST="i386" \
34 PREFIX="%{_prefix}" \
35 TINYCC_INSTALLDIR="%{tinyccdir}" make/make.sh i386
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT{%{_bindir},%{tinyccdir}/{lib,include}}
40 install libtinyccrt-*.a libtinycc-*.so $RPM_BUILD_ROOT%{tinyccdir}/lib
41 install include/* $RPM_BUILD_ROOT%{tinyccdir}/include
42 install *-tinycc $RPM_BUILD_ROOT%{_bindir}
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc Changelog README TODO www/*
50 %attr(755,root,root) %{_bindir}/*
51 %dir %{tinyccdir}
52 %dir %{tinyccdir}/include
53 %dir %{tinyccdir}/lib
54 %{tinyccdir}/include/*
55 %{tinyccdir}/lib/*.a
56 %attr(755,root,root) %{tinyccdir}/lib/*.so
This page took 0.14936 seconds and 3 git commands to generate.