]> git.pld-linux.org Git - SPECS.git/blob - tevent.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / tevent.spec
1 Summary:        An event system library
2 Summary(pl.UTF-8):      Biblioteka systemu zdarzeń
3 Name:           tevent
4 Version:        0.10.2
5 Release:        2
6 License:        LGPL v3+
7 Group:          Libraries
8 Source0:        https://www.samba.org/ftp/tevent/%{name}-%{version}.tar.gz
9 # Source0-md5:  105c7a4dbb96f1751eb27dfd05e7fa84
10 URL:            https://tevent.samba.org/
11 BuildRequires:  libbsd-devel
12 BuildRequires:  python3-devel >= 1:3.2
13 BuildRequires:  python3-talloc-devel >= 2:2.3.0
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.704
16 BuildRequires:  talloc-devel >= 2:2.3.0
17 # tevent 0.10+ dropped python2 support
18 Obsoletes:      python-tevent
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Tevent is an event system based on the talloc memory management
23 library. It is the core event system used in Samba.
24
25 The low level tevent has support for many event types, including
26 timers, signals, and the classic file descriptor events.
27
28 Tevent also provide helpers to deal with asynchronous code providing
29 the tevent_req (tevent request) functions.
30
31 %description -l pl.UTF-8
32 Tevent to system zdarzeń oparty na bibliotece zarządzającej pamięcią
33 talloc. Jest to główny system zdarzeń używany w Sambie.
34
35 Niskopoziomowo tevent obsługuje wiele rodzajów zdarzeń, w tym
36 zegary, sygnały i zdarzenia związane z klasycznymi deskryptorami
37 plików.
38
39 Tevent udostępnia także funkcje pomocnicze tevent_req (żądanie tevent)
40 dla kodu asynchronicznego.
41
42 %package devel
43 Summary:        Header files for tevent library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki tevent
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       talloc-devel >= 2:2.3.0
48
49 %description devel
50 Header files for tevent library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki tevent.
54
55 %package -n python3-tevent
56 Summary:        Python 3 bindings for tevent
57 Summary(pl.UTF-8):      Interfejs Pythona 3 do tevent
58 Group:          Libraries/Python
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       python3-talloc >= 2:2.3.0
61
62 %description -n python3-tevent
63 Python 3 bindings for tevent.
64
65 %description -n python3-tevent -l pl.UTF-8
66 Interfejs Pythona 3 do tevent.
67
68 %prep
69 %setup -q
70
71 %build
72 export JOBS=1
73
74 CC="%{__cc}" \
75 CFLAGS="%{rpmcflags}" \
76 %{__python3} buildtools/bin/waf configure \
77         --prefix=%{_prefix} \
78         --libdir=%{_libdir} \
79         --disable-rpath
80
81 %{__make} \
82         V=1
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
91 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/libtevent.so.*.*.*
102 %attr(755,root,root) %ghost %{_libdir}/libtevent.so.0
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/libtevent.so
107 %{_includedir}/tevent.h
108 %{_pkgconfigdir}/tevent.pc
109
110 %files -n python3-tevent
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{py3_sitedir}/_tevent.cpython-*.so
113 %{py3_sitedir}/tevent.py
114 %{py3_sitedir}/__pycache__/tevent.cpython-*.py[co]
This page took 0.136014 seconds and 3 git commands to generate.