]> git.pld-linux.org Git - SPECS.git/blob - syck.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / syck.spec
1 %bcond_without  python  # do not compile python bindings
2 Summary:        Library for reading and writing YAML in scripting languages
3 Summary(pl.UTF-8):      Biblioteka do odczytu i zapisu YAML-a w językach skryptowych
4 Name:           syck
5 Version:        0.55
6 Release:        4
7 License:        BSD
8 Group:          Libraries
9 Source0:        http://rubyforge.org/frs/download.php/4492/%{name}-%{version}.tar.gz
10 # Source0-md5:  a57b7c46d81170b9318e2f384f77910c
11 Patch0:         %{name}-shared.patch
12 URL:            http://whytheluckystiff.net/syck/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libtool
16 %if %{with python}
17 BuildRequires:  python-devel >= 1:2.5
18 BuildRequires:  rpm-pythonprov
19 %endif
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Syck is an extension for reading and writing YAML swiftly in popular
24 scripting languages. As Syck loads the YAML, it stores the data
25 directly in your language's symbol table. This means speed. This means
26 power. This means Do not disturb Syck because it is so focused on the
27 task at hand that it will slay you mortally if you get in its way.
28
29 %description -l pl.UTF-8
30 Syck to rozszerzenie do szybkiego odczytu i zapisu YAML-a w
31 popularnych językach skryptowych. Po wczytaniu YAML-a Syck zapisuje
32 dane bezpośrednio do tablicy symboli używanego języka. To oznacza
33 szybkość. To oznacza potęgę. To oznacza, że nie należy przeszkadzać
34 Syckowi, ponieważ tak skupia się na własnym zadaniu, że zabije, jeśli
35 wejdziemy mu w drogę.
36
37 %package devel
38 Summary:        Header files for syck library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki syck
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for syck library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki syck.
48
49 %package static
50 Summary:        Static syck library
51 Summary(pl.UTF-8):      Statyczna biblioteka syck
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static syck library.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka syck.
60
61 %package -n python-syck
62 Summary:        Python bindings for syck library
63 Summary(pl.UTF-8):      Pythonowy interfejes do biblioteki syck
64 Group:          Libraries/Python
65 #Requires:      %{name} = %{version}-%{release}
66 %pyrequires_eq  python
67
68 %description -n python-syck
69 Python bindings for syck library.
70
71 %description -n python-syck -l pl.UTF-8
72 Pythonowy interfejs do biblioteki syck.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77
78 %build
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 %configure 
85
86 %{__make} \
87         CFLAGS="%{rpmcflags} -fPIC"
88
89 %if %{with python}
90 cd ext/python
91 CFLAGS="%{rpmcflags} -fPIC"
92 %py_build
93 cd ..
94 %endif
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %if %{with python}
103 cd ext/python
104 %py_install
105
106 install -d $RPM_BUILD_ROOT%{py_sitescriptdir}
107 %{__mv} $RPM_BUILD_ROOT%{py_sitedir}/{*.py[co],*.egg-info} $RPM_BUILD_ROOT%{py_sitescriptdir}
108 find $RPM_BUILD_ROOT%{py_sitedir} -name \*.py | xargs rm -f
109 %endif
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc CHANGELOG COPYING README README.BYTECODE RELEASE tests
120 %attr(755,root,root) %{_libdir}/libsyck.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libsyck.so.0
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libsyck.so
126 %{_libdir}/libsyck.la
127 %{_includedir}/syck*.h
128
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/libsyck.a
132
133 %if %{with python}
134 %files -n python-syck
135 %defattr(644,root,root,755)
136 %doc ext/python/tests
137 %{py_sitescriptdir}/yaml2xml.py[co]
138 %{py_sitescriptdir}/ydump.py[co]
139 %{py_sitescriptdir}/ypath.py[co]
140 %{py_sitescriptdir}/Syck-*.egg-info
141 %{py_sitedir}/syck.so
142 %endif
This page took 0.111767 seconds and 3 git commands to generate.