]> git.pld-linux.org Git - SPECS.git/blob - svnfiltereddump.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / svnfiltereddump.spec
1 %define         subver  beta4
2 %define         rel             2
3 Summary:        Tool to extract portions from Subversion repositories
4 Name:           svnfiltereddump
5 Version:        1.0
6 Release:        0.%{subver}.%{rel}
7 License:        GPL v3+
8 Group:          Development/Version Control
9 Source0:        https://github.com/TNG/svnfiltereddump/tarball/master/%{name}-%{version}%{subver}.tgz
10 # Source0-md5:  a0471604afd2edc8ff0df878cd7b5ee7
11 URL:            https://github.com/TNG/svnfiltereddump
12 BuildRequires:  python-devel >= 1:2.6
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  rpmbuild(macros) >= 1.219
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 The svnfiltereddump tool is meant to extract portions of repositories
20 of the Subversion source control system. It's output can be loaded
21 with Subversion's "svnadmin load" command into a new Subversion
22 repository. The source repository must be given on the command line. A
23 list of paths to extract may given on command line or in one or more
24 input file(s). It is also possible to skip the revision history before
25 a given starting revision.
26
27 %prep
28 %setup -qc
29 mv *-%{name}-*/* .
30
31 %build
32 %{__python} setup.py build
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT%{_mandir}/man1
37 %{__python} setup.py install \
38         --skip-build \
39         --optimize=2 \
40         --root=$RPM_BUILD_ROOT
41
42 %py_postclean
43
44 cp -p man/man1/svnfiltereddump.1 $RPM_BUILD_ROOT%{_mandir}/man1
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %attr(755,root,root) %{_bindir}/%{name}
52 %{_mandir}/man1/%{name}.1*
53 %{py_sitescriptdir}/%{name}
54 %{py_sitescriptdir}/%{name}-%{version}%{subver}-py*.egg-info
This page took 0.472283 seconds and 3 git commands to generate.