]> git.pld-linux.org Git - SPECS.git/blob - supybot.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / supybot.spec
1 %define         origname        Supybot
2 Summary:        A cross-platform IRC bot written in Python
3 Summary(pl.UTF-8):      Wieloplatformowy bot IRC-owy napisany w Pythonie
4 Name:           supybot
5 Version:        0.83.4.1
6 Release:        1
7 Group:          Applications/Networking
8 # The entire source code is BSD except for
9 # Supybot-0.83.4/plugins/Math/local/convertcore.py which is GPL v2
10 License:        BSD and GPL v2
11 URL:            http://supybot.com/
12 Source0:        http://downloads.sourceforge.net/supybot/%{origname}-%{version}.tar.bz2
13 # Source0-md5:  96ce90559c7d6fde5e3c93174c509408
14 # Fix a conflict between python-json and the built in json module
15 # in Python 2.6.  Already submitted and commited upstream.
16 Patch0:         json.patch
17 # fix karma plugin to actually work should go upstream
18 Patch1:         karma-plugin.patch
19 BuildRequires:  python-distribute
20 BuildRequires:  python-modules
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.219
23 Requires:       python-TwistedCore
24 Requires:       python-TwistedNames
25 Requires:       python-dateutil
26 Requires:       python-dictclient
27 Requires:       python-feedparser
28 Requires:       python-simplejson
29 Provides:       Supybot = %{version}-%{release}
30 Obsoletes:      Supybot < %{version}-%{release}
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Supybot is a cross-platform IRC bot written in Python, known to run
36 anywhere Python runs.
37
38 - Supybot is actively developed.
39 - Supybot offers nested commands.
40 - Supybot has a powerful and flexible capability system for handling
41   security.
42 - Supybot includes many plugins, and has many more ripe for the
43   picking on this very website.
44 - Supybot supports multiple servers.
45 - Supybot supports multiple channels.
46 - Supybot is user-friendly.
47 - Supybot is developer-friendly.
48
49 %description -l pl.UTF-8
50 Supybot to wieloplatformowy bot IRC-owy napisany w Pythonie,
51 działający na wszystkich platformach obsługiwanych przez Pythona.
52
53 - Jest aktywnie rozwijany.
54 - Oferuje zagnieżdżone polecenia.
55 - Ma potężny i elastyczny system uprawnień do obsługi bezpieczeństwa.
56 - Zawiera wiele wtyczek i można ich pobrać jeszcze więcej ze strony.
57 - Obsługuje wiele serwerów.
58 - Obsługuje wiele kanałów.
59 - Jest przyjazny dla użytkowników.
60 - Jest przyjazny dla programistów.
61
62 %prep
63 %setup -q -n %{origname}-%{version}
64 %patch0 -p1
65 %patch1 -p1
66
67 %build
68 %{__python} setup.py build
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 %{__python} setup.py install \
73         --skip-build \
74         --optimize=2 \
75         --root=$RPM_BUILD_ROOT
76
77 %py_postclean
78
79 install -d $RPM_BUILD_ROOT%{_mandir}/man1
80 cp -a docs/man/supybot.1 $RPM_BUILD_ROOT%{_mandir}/man1
81 cp -a docs/man/supybot-adduser.1 $RPM_BUILD_ROOT%{_mandir}/man1
82 cp -a docs/man/supybot-botchk.1 $RPM_BUILD_ROOT%{_mandir}/man1
83 cp -a docs/man/supybot-plugin-create.1 $RPM_BUILD_ROOT%{_mandir}/man1
84 cp -a docs/man/supybot-plugin-doc.1 $RPM_BUILD_ROOT%{_mandir}/man1
85 cp -a docs/man/supybot-test.1 $RPM_BUILD_ROOT%{_mandir}/man1
86 cp -a docs/man/supybot-wizard.1 $RPM_BUILD_ROOT%{_mandir}/man1
87
88 # These are provided in python-feedparser, python-dateutil,
89 # python-dictclient, and python-simplejson
90 rm -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/supybot/plugins/RSS/local
91 rm -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/supybot/plugins/Time/local
92 rm -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/supybot/plugins/Dict/local
93 rm -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/supybot/plugins/Google/local
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %doc ACKS ChangeLog LICENSE README RELNOTES
101 %doc docs/{ADVANCED_PLUGIN_CONFIG,ADVANCED_PLUGIN_TESTING,CAPABILITIES}
102 %doc docs/{CONFIGURATION,FAQ,GETTING_STARTED,PLUGIN_TUTORIAL,STYLE}
103 %doc docs/{USING_UTILS,USING_WRAP}
104 %attr(755,root,root) %{_bindir}/supybot
105 %attr(755,root,root) %{_bindir}/supybot-adduser
106 %attr(755,root,root) %{_bindir}/supybot-botchk
107 %attr(755,root,root) %{_bindir}/supybot-plugin-create
108 %attr(755,root,root) %{_bindir}/supybot-plugin-doc
109 %attr(755,root,root) %{_bindir}/supybot-plugin-package
110 %attr(755,root,root) %{_bindir}/supybot-test
111 %attr(755,root,root) %{_bindir}/supybot-wizard
112 %{py_sitescriptdir}/supybot
113 %if "%{py_ver}" > "2.4"
114 %{py_sitescriptdir}/supybot-*.egg-info
115 %endif
116 %{_mandir}/man1/supybot.1*
117 %{_mandir}/man1/supybot-adduser.1*
118 %{_mandir}/man1/supybot-botchk.1*
119 %{_mandir}/man1/supybot-plugin-create.1*
120 %{_mandir}/man1/supybot-plugin-doc.1*
121 %{_mandir}/man1/supybot-test.1*
122 %{_mandir}/man1/supybot-wizard.1*
This page took 0.081254 seconds and 3 git commands to generate.