]> git.pld-linux.org Git - SPECS.git/blob - supertux.spec
SPECS updated Wed 1 May 10:14:00 CEST 2024
[SPECS.git] / supertux.spec
1 %bcond_with discord     # Discord integration
2 #
3 Summary:        Game similar to the original game Super Mario Bros
4 Summary(pl.UTF-8):      Gra podobna do oryginalnej gry Super Mario Bros
5 Name:           supertux
6 Version:        0.6.3
7 Release:        1
8 License:        GPL
9 Group:          X11/Applications/Games
10 Source0:        https://github.com/SuperTux/supertux/releases/download/v%{version}/SuperTux-v%{version}-Source.tar.gz
11 # Source0-md5:  798d5518d3f4672ee0bac92693063c2f
12 Patch0:         %{name}-0.6.3-missing-headers.patch
13 URL:            https://www.supertux.org
14 BuildRequires:  GLM
15 BuildRequires:  OpenAL-devel
16 BuildRequires:  OpenGL-devel
17 BuildRequires:  SDL2-devel >= 2.0.1
18 BuildRequires:  SDL2_image-devel >= 2.0.0
19 BuildRequires:  boost-devel
20 BuildRequires:  cmake
21 BuildRequires:  curl-devel
22 BuildRequires:  doxygen
23 BuildRequires:  freetype-devel
24 BuildRequires:  fribidi-devel
25 BuildRequires:  glew-devel
26 BuildRequires:  graphviz
27 BuildRequires:  harfbuzz-devel
28 BuildRequires:  libogg-devel
29 BuildRequires:  libpng-devel
30 BuildRequires:  libraqm-devel
31 BuildRequires:  libvorbis-devel
32 BuildRequires:  physfs-devel
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpmbuild(macros) >= 1.742
35 BuildRequires:  zlib-devel
36 Requires:       OpenGL
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 #%define        _noautoreqdep   libGL.so.1 libGLU.so.1
40
41 %description
42 Super Mario Bros style game starring Tux the penguin.
43
44 %description -l pl.UTF-8
45 Gra w stylu Super Mario Bros z pingwinem Tuksem w roli głównej.
46
47 %post
48 %update_desktop_database_post
49 %update_icon_cache hicolor
50
51 %postun
52 %update_desktop_database_postun
53 %update_icon_cache hicolor
54
55 %prep
56 %setup -q -n SuperTux-v%{version}-Source
57 %patch0 -p1
58
59 %build
60 mkdir -p build
61 cd build
62 %cmake .. \
63         -DINSTALL_SUBDIR_BIN=bin \
64         %{cmake_on_off discord ENABLE_DISCORD} \
65         -DCMAKE_BUILD_TYPE=RelWithDebInfo
66
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 cd build
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/supertux2
76
77 %if %{with discord}
78 %{__rm} $RPM_BUILD_ROOT%{_includedir}/discord_*.h
79 %endif
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc CODINGSTYLE.md CONTRIBUTING.md NEWS.md README.md
87 %attr(755,root,root) %{_bindir}/supertux2
88 %{_datadir}/games/supertux2
89 %{_desktopdir}/supertux2.desktop
90 %{_iconsdir}/hicolor/scalable/apps/supertux2.svg
91 %{_datadir}/metainfo/supertux2.appdata.xml
92 %{_pixmapsdir}/supertux.png
93 %{_pixmapsdir}/supertux.xpm
94 %if %{with discord}
95 %{_libdir}/libdiscord-rpc.so
96 %endif
This page took 0.131234 seconds and 4 git commands to generate.