]> git.pld-linux.org Git - SPECS.git/blob - smack.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / smack.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        SMACK userspace package
7 Summary(pl.UTF-8):      Pakiet SMACK dla przestrzeni użytkownika
8 Name:           smack
9 Version:        1.3.1
10 Release:        1
11 License:        LGPL v2.1
12 Group:          Libraries
13 #Source0Download: https://github.com/smack-team/smack/releases
14 Source0:        https://github.com/smack-team/smack/archive/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  f80d163127c0db8441faf3bbb7d887da
16 URL:            https://github.com/smack-team/smack
17 BuildRequires:  autoconf >= 2.60
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  doxygen
20 BuildRequires:  libtool >= 2:2.2
21 BuildRequires:  pkgconfig
22 BuildRequires:  systemd-devel >= 1:198
23 Requires:       %{name}-libs = %{version}-%{release}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Simplified Mandatory Access Control Kernel (SMACK) provides a
28 complete Linux kernel based mechanism for protecting processes and
29 data from inappropriate manipulation. Smack uses process, file, and
30 network labels combined with an easy to understand and manipulate way
31 to identify the kind of accesses that should be allowed.
32
33 %description -l pl.UTF-8
34 SMACK (Simplified Mandatory Access Control Kernel - uproszczone jądro
35 obowiązkowej kontroli dostępu) to oparty na jądrze Linuksa kompletny
36 mechanizm ochrony procesów i danych od niewłaściwych operacji. Smack
37 wykorzystuje etykiety procesów, plików oraz sieci w połączeniu z
38 łatwymi do zrozumienia i operowania rodzajami dostępu, który powinien
39 być dozwolony.
40
41 %package libs
42 Summary:        Shared library for interaction with SMACK
43 Summary(pl.UTF-8):      Biblioteka współdzielona do współpracy z systemem SMACK
44 Group:          Libraries
45
46 %description libs
47 Shared library for interaction with SMACK.
48
49 %description libs -l pl.UTF-8
50 Biblioteka współdzielona do współpracy z systemem SMACK.
51
52 %package devel
53 Summary:        Header file for SMACK library
54 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki SMACK
55 Group:          Development/Libraries
56 Requires:       %{name}-libs = %{version}-%{release}
57
58 %description devel
59 Header file for SMACK library.
60
61 %description devel -l pl.UTF-8
62 Plik nagłówkowy biblioteki SMACK.
63
64 %package static
65 Summary:        Static SMACK library
66 Summary(pl.UTF-8):      Statyczna biblioteka SMACK
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static SMACK library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka SMACK.
75
76 %package apidocs
77 Summary:        SMACK API documentation
78 Summary(pl.UTF-8):      Dokumentacja API biblioteki SMACK
79 Group:          Documentation
80 BuildArch:      noarch
81
82 %description apidocs
83 API documentation for SMACK library.
84
85 %description apidocs -l pl.UTF-8
86 Dokumentacja API biblioteki SMACK.
87
88 %prep
89 %setup -q
90
91 %build
92 %{__libtoolize}
93 %{__aclocal} -I m4
94 %{__autoconf}
95 %{__autoheader}
96 %{__automake}
97 %configure \
98         --disable-silent-rules \
99         %{?with_static_libs:--enable-static}
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 # obsoleted by pkg-config
109 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsmack.la
110 # packaged unarchived in -apidocs
111 %{__rm} $RPM_BUILD_ROOT%{_docdir}/libsmack/libsmack-%{version}-doc.tar.gz
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   libs -p /sbin/ldconfig
117 %postun libs -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_bindir}/chsmack
122 %attr(755,root,root) %{_bindir}/smackaccess
123 %attr(755,root,root) %{_bindir}/smackcipso
124 %attr(755,root,root) %{_bindir}/smackctl
125 %attr(755,root,root) %{_bindir}/smackload
126 %{_mandir}/man1/smackaccess.1*
127 %{_mandir}/man8/chsmack.8*
128 %{_mandir}/man8/smackcipso.8*
129 %{_mandir}/man8/smackctl.8*
130 %{_mandir}/man8/smackload.8*
131
132 %files libs
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/libsmack.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libsmack.so.1
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libsmack.so
140 %{_includedir}/sys/smack.h
141 %{_pkgconfigdir}/libsmack.pc
142 %{_mandir}/man3/SMACK_LABEL_LEN.3*
143 %{_mandir}/man3/smack.h.3*
144 %{_mandir}/man3/smack_*.3*
145
146 %if %{with static_libs}
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libsmack.a
150 %endif
151
152 %if %{with apidocs}
153 %files apidocs
154 %defattr(644,root,root,755)
155 %doc doc/html/*
156 %endif
This page took 0.154247 seconds and 3 git commands to generate.