]> git.pld-linux.org Git - SPECS.git/blob - simage.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / simage.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_with     qt              # load/save images using Qt
5 %bcond_with     qt4             # Qt4 instead of Qt5
6 #
7 Summary:        Library with image format loaders and front-ends to common import libraries
8 Summary(pl.UTF-8):      Biblioteka z wczytywaniem formatów obrazów oraz frontendami do popularnych bibliotek importujących
9 Name:           simage
10 Version:        1.8.0
11 Release:        1
12 License:        MIT, MPEG
13 Group:          Libraries
14 #Source0Download: https://github.com/coin3d/simage/releases
15 Source0:        https://github.com/coin3d/simage/releases/download/simage-%{version}/%{name}-%{version}-src.tar.gz
16 # Source0-md5:  a1810e0c2a1c9c7a6c191198bd8465bc
17 Patch0:         %{name}-gifutil.patch
18 Patch1:         %{name}-doxygen.patch
19 Patch2:         %{name}-link.patch
20 URL:            https://github.com/coin3d/simage
21 %if %{with qt}
22 %if %{with qt4}
23 BuildRequires:  QtCore-devel >= 4
24 BuildRequires:  QtGui-devel >= 4
25 %else
26 BuildRequires:  Qt5Core-devel >= 5
27 BuildRequires:  Qt5Gui-devel >= 5
28 %endif
29 %endif
30 BuildRequires:  cmake >= 3.0
31 %{?with_apidocs:BuildRequires:  doxygen}
32 BuildRequires:  giflib-devel >= 5.2.1-2
33 BuildRequires:  jasper-devel
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libogg-devel
36 BuildRequires:  libpng-devel
37 BuildRequires:  libsndfile-devel
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtiff-devel
40 BuildRequires:  libvorbis-devel
41 BuildRequires:  rpmbuild(macros) >= 1.752
42 BuildRequires:  zlib-devel
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 This is simage, a library with image format loaders and front-ends to
47 common import libraries. simage is meant for use with applications
48 which reads image files as textures.
49
50 %description -l pl.UTF-8
51 Ten pakiet zawiera bibliotekę simage, obsługującą wczytywanie różnych
52 formatów obrazów oraz frontendy do popularnych bibliotek
53 importujących. Biblioteka jest przeznaczona do użycia w aplikacjach
54 czytających pliki obrazów jako tekstury.
55
56 %package devel
57 Summary:        Header files for simage library
58 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki simage
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description devel
63 Header files for simage library.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki simage.
67
68 %package apidocs
69 Summary:        API documentation for simage library
70 Summary(pl.UTF-8):      Dokumentacja API biblioteki simage
71 Group:          Documentation
72 BuildArch:      noarch
73
74 %description apidocs
75 API documentation for simage library.
76
77 %description apidocs -l pl.UTF-8
78 Dokumentacja API biblioteki simage.
79
80 %prep
81 %setup -q -n %{name}
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85
86 %build
87 install -d builddir
88 cd builddir
89 %cmake .. \
90         %{?with_apidocs:-DSIMAGE_BUILD_DOCUMENTATION=ON} \
91         %{?with_qt:-DSIMAGE_USE_QIMAGE=ON} \
92         %{?with_qt4:-DSIMAGE_USE_QT5=OFF} \
93         -DSIMAGE_XWD_SUPPORT=ON
94
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} -C builddir install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 # packaged as %doc
104 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/html
105 # bogus location
106 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}/simage1
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS COPYING ChangeLog LICENSE LICENSE.mpeg2enc NEWS README
117 %attr(755,root,root) %{_libdir}/libsimage.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libsimage.so.20
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libsimage.so
123 %{_includedir}/simage.h
124 %{_pkgconfigdir}/simage.pc
125 %{_libdir}/cmake/simage-%{version}
126
127 %if %{with apidocs}
128 %files apidocs
129 %defattr(644,root,root,755)
130 %doc builddir/html/*
131 %endif
This page took 0.4632 seconds and 3 git commands to generate.