]> git.pld-linux.org Git - SPECS.git/blob - sa.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / sa.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 %bcond_without  tests           # don't perform "make check"
5 #
6 Summary:        OSSP sa - Socket Abstraction
7 Summary(pl.UTF-8):      OSSP sa - biblioteka abstrakcji gniazd
8 Name:           sa
9 Version:        1.2.6
10 Release:        0.1
11 Epoch:          0
12 License:        distributable (see README)
13 Group:          Libraries
14 Source0:        ftp://ftp.ossp.org/pkg/lib/sa/%{name}-%{version}.tar.gz
15 # Source0-md5:  45317c5529b3ce8acbdaeb93aff4ad16
16 Patch0:         %{name}-libs.patch
17 URL:            http://www.ossp.org/pkg/lib/sa/
18 BuildRequires:  ex-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 OSSP sa is an abstraction library for the Unix socket application
23 programming interface (API) featuring stream and datagram oriented
24 communication over Unix Domain and Internet Domain (TCP and UDP)
25 sockets. It provides the following key features: address abstraction
26 (local, IPv4, and IPv6), type abstraction, I/O timeouts, I/O stream
27 buffering and convenience I/O functions.
28
29 %description -l pl.UTF-8
30 OSSP sa to biblioteka abstrakcji dla uniksowego API gniazd z obsługą
31 komunikacji zorientowanej na strumienie i datagramy poprzez gniazda
32 uniksowe i internetowe (TCP i UDP). Kluczowe możliwości to: abstrakcja
33 adresów (lokalnych, IPv4, IPv6), abstrakcja typów, timeouty
34 wejścia/wyjścia, timeouty buforowania strumieni i wygodne funkcje
35 wejścia/wyjścia.
36
37 %package devel
38 Summary:        OSSP sa - Socket Abstraction - header files
39 Summary(pl.UTF-8):      OSSP sa - biblioteka Socket Abstraction - pliki nagłówkowe
40 Group:          Development/Libraries
41 Requires:       %{name} = %{epoch}:%{version}-%{release}
42
43 %description devel
44 OSSP sa - Socket Abstraction - header files.
45
46 %description devel -l pl.UTF-8
47 OSSP sa - biblioteka Socket Abstraction - pliki nagłówkowe.
48
49 %package static
50 Summary:        OSSP sa - Socket Abstraction - static libraries
51 Summary(pl.UTF-8):      OSSP sa - biblioteka Socket Abstraction - biblioteki statyczne
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
54
55 %description static
56 OSSP sa - Socket Abstraction - static libraries.
57
58 %description static -l pl.UTF-8
59 OSSP sa - biblioteka Socket Abstraction - biblioteki statyczne.
60
61 %prep
62 %setup -q
63 %patch0 -p1
64
65 %build
66 %configure \
67         --with-ex \
68         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no}
69 %{__make}
70
71 %{?with_tests:%{__make} check}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post   -p /sbin/ldconfig
83 %postun -p /sbin/ldconfig
84
85 %files
86 %defattr(644,root,root,755)
87 %doc AUTHORS ChangeLog README THANKS TODO
88 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_bindir}/*
93 %attr(755,root,root) %{_libdir}/lib*.so
94 %{_libdir}/lib*.la
95 %{_includedir}/*
96 %{_pkgconfigdir}/*.pc
97 %{_mandir}/man3/*
98
99 %if %{with static_libs}
100 %files static
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_libdir}/lib*.a
103 %endif
This page took 0.230582 seconds and 3 git commands to generate.