]> git.pld-linux.org Git - SPECS.git/blob - rudiments.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / rudiments.spec
1 #
2 # Conditional build:
3 %bcond_with     apache  # Apache 2 support (too messy for now, adds flags to librudiments)
4
5 Summary:        C++ class library for daemons, clients and servers
6 Summary(pl.UTF-8):      Biblioteka klas C++ dla demonów, klientów i serwerów
7 Name:           rudiments
8 Version:        1.3.0
9 Release:        1
10 License:        LGPL v2+
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/rudiments/%{name}-%{version}.tar.gz
13 # Source0-md5:  06e5e81901f8bd6d2a9f0b2b1a4f9993
14 Patch0:         %{name}-pc.patch
15 URL:            http://rudiments.sourceforge.net/
16 BuildRequires:  automake
17 BuildRequires:  curl-devel >= 7.15.2
18 BuildRequires:  heimdal-devel
19 BuildRequires:  libedit-devel
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  openssl-devel
22 BuildRequires:  pcre-devel
23 %if %{with apache}
24 BuildRequires:  apache-devel >= 2
25 BuildRequires:  apr-devel
26 BuildRequires:  apr-util-devel
27 %endif
28 Requires:       curl-libs >= 7.15.2
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Rudiments is an Open Source C++ class library providing base classes
33 for things such as daemons, clients and servers, and wrapper classes
34 for the standard C functions for things like such as regular
35 expressions, semaphores and signal handling.
36
37 %description -l pl.UTF-8
38 Rudiments to mająca otwarte źródła biblioteka klas C++ dostarczająca
39 klasy bazowe do tworzenia demonów, klientów i serwerów oraz klasy
40 obudowujące dla standardowych funkcji C obsługujących wyrażenia
41 regularne, semafory, sygnały itp.
42
43 %package devel
44 Summary:        Header files for rudiments library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki rudiments
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       curl-devel >= 7.15.2
49 Requires:       heimdal-devel
50 Requires:       libedit-devel
51 Requires:       libstdc++-devel
52 Requires:       openssl-devel
53 Requires:       pcre-devel
54
55 %description devel
56 Header files for rudiments library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki rudiments.
60
61 %package static
62 Summary:        Static rudiments library
63 Summary(pl.UTF-8):      Statyczna biblioteka rudiments
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static rudiments library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka rudiments.
72
73 %package doc
74 Summary:        Documentation for rudiments
75 Summary(pl.UTF-8):      Dokumentacja dla biblioteki rudiments
76 Group:          Documentation
77
78 %description doc
79 Documentation for rudiments.
80
81 %description doc -l pl.UTF-8
82 Dokumentacja dla biblioteki rudiments.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87
88 %build
89 cp -f /usr/share/automake/config.sub .
90 %configure \
91         %{!?with_apache:--disable-apache2}
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
101 cat >$RPM_BUILD_ROOT%{systemdtmpfilesdir}/rudiments.conf <<EOF
102 d /var/run/rudiments 1777 root root -
103 EOF
104
105 # obsoleted by pkg-config
106 %{__rm} $RPM_BUILD_ROOT%{_libdir}/librudiments.la
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS ChangeLog
117 %attr(755,root,root) %{_libdir}/librudiments.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/librudiments.so.7
119 %attr(1777,root,root) %dir /var/run/rudiments
120 %{systemdtmpfilesdir}/rudiments.conf
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_bindir}/rudiments-config
125 %attr(755,root,root) %{_libdir}/librudiments.so
126 %{_includedir}/rudiments
127 %{_pkgconfigdir}/rudiments.pc
128 %{_mandir}/man1/rudiments-config.1*
129
130 %files static
131 %defattr(644,root,root,755)
132 %{_libdir}/librudiments.a
133
134 %files doc
135 %defattr(644,root,root,755)
136 %{_docdir}/%{name}
This page took 0.408423 seconds and 3 git commands to generate.