]> git.pld-linux.org Git - SPECS.git/blob - ruby-rack-mount.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / ruby-rack-mount.spec
1 %define pkgname rack-mount
2 Summary:        A stackable dynamic tree based Rack router
3 Name:           ruby-%{pkgname}
4 Version:        0.6.1
5 Release:        1
6 License:        MIT
7 Group:          Development/Libraries
8 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
9 # Source0-md5:  6fe33c194d4b63817bd6ab857ff720a7
10 URL:            http://github.com/josh/rack-mount
11 BuildRequires:  rpmbuild(macros) >= 1.484
12 BuildRequires:  ruby >= 1:1.8.6
13 BuildRequires:  ruby-modules
14 Requires:       ruby-rack
15 %{?ruby_mod_ver_requires_eq}
16 #BuildArch:     noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Rack::Mount supports Rack’s Cascade style of trying several routes
21 until it finds one that is not a 404. This allows multiple routes to
22 be nested or stacked on top of each other. Since the application
23 endpoint can trigger the router to continue matching, middleware can
24 be used to add arbitrary conditions to any route. This allows you to
25 route based on other request attributes, session information, or even
26 data dynamically pulled from a database.
27
28 %package rdoc
29 Summary:        HTML documentation for %{pkgname}
30 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
31 Group:          Documentation
32 Requires:       ruby >= 1:1.8.7-4
33
34 %description rdoc
35 HTML documentation for %{pkgname}.
36
37 %description rdoc -l pl.UTF-8
38 Dokumentacja w formacie HTML dla %{pkgname}.
39
40 %package ri
41 Summary:        ri documentation for %{pkgname}
42 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
43 Group:          Documentation
44 Requires:       ruby
45
46 %description ri
47 ri documentation for %{pkgname}.
48
49 %description ri -l pl.UTF-8
50 Dokumentacji w formacie ri dla %{pkgname}.
51
52 %prep
53 %setup -q -c
54 %{__tar} xf %{SOURCE0} -O data.tar.gz | %{__tar} xz
55 find -newer README.rdoc -o -print | xargs touch --reference %{SOURCE0}
56
57 %build
58 rdoc --ri --op ri lib
59 rdoc --op rdoc lib
60 rm -r ri/{Multimap,Multiset,NestedMultimap,Reginald,Rack/cdesc-Rack.yaml}
61 rm ri/created.rid
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT{%{_bindir},%{ruby_rubylibdir},%{ruby_ridir},%{ruby_rdocdir}}
66
67 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
68 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
69 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc README.rdoc
77 %{ruby_rubylibdir}/rack/mount
78 %{ruby_rubylibdir}/rack/mount.rb
79
80 %files rdoc
81 %defattr(644,root,root,755)
82 %{ruby_rdocdir}/%{name}-%{version}
83
84 %files ri
85 %defattr(644,root,root,755)
86 %{ruby_ridir}/Rack/Mount
This page took 0.328401 seconds and 3 git commands to generate.