]> git.pld-linux.org Git - SPECS.git/blob - ruby-pry.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / ruby-pry.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname pry
6 Summary:        An IRB alternative and runtime developer console
7 Name:           ruby-%{pkgname}
8 Version:        0.9.12.2
9 Release:        2
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  c5d654869df4ba75715a399935fc8114
14 URL:            http://pry.github.com/
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 BuildRequires:  sed >= 4.0
18 %if %{with tests}
19 BuildRequires:  ruby-bacon < 2
20 BuildRequires:  ruby-bacon >= 1.2
21 BuildRequires:  ruby-bond < 0.5
22 BuildRequires:  ruby-bond >= 0.4.2
23 BuildRequires:  ruby-guard < 1.4
24 BuildRequires:  ruby-guard >= 1.3.2
25 BuildRequires:  ruby-mocha < 0.14
26 BuildRequires:  ruby-mocha >= 0.13.1
27 BuildRequires:  ruby-open4 < 2
28 BuildRequires:  ruby-open4 >= 1.3
29 BuildRequires:  ruby-rake < 1
30 BuildRequires:  ruby-rake >= 0.9
31 %endif
32 Requires:       ruby-coderay < 1.1
33 Requires:       ruby-coderay >= 1.0.5
34 Requires:       ruby-method_source < 1
35 Requires:       ruby-method_source >= 0.8
36 Requires:       ruby-slop < 4
37 Requires:       ruby-slop >= 3.4
38 BuildArch:      noarch
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 An IRB alternative and runtime developer console
43
44 %package doc
45 Summary:        Documentation for %{name}
46 Group:          Documentation
47 Requires:       %{name} = %{version}-%{release}
48
49 %description doc
50 Documentation for %{name}.
51
52 %prep
53 %setup -q -n %{pkgname}-%{version}
54 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
55
56 %build
57 # write .gemspec
58 %__gem_helper spec
59
60 %if %{with tests}
61 bacon -Ispec -q spec/*_spec.rb
62 %endif
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir},%{_mandir}/man1}
67 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
68 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
69 cp -a man/pry.1 $RPM_BUILD_ROOT%{_mandir}/man1
70 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc README.markdown LICENSE CHANGELOG CONTRIBUTORS
78 %attr(755,root,root) %{_bindir}/pry
79 %{_mandir}/man1/pry.1*
80 %{ruby_vendorlibdir}/pry.rb
81 %{ruby_vendorlibdir}/pry
82 %{ruby_specdir}/pry-%{version}.gemspec
This page took 0.515158 seconds and 3 git commands to generate.