]> git.pld-linux.org Git - SPECS.git/blob - ruby-platform.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / ruby-platform.spec
1 # NOTE:
2 # http://rubygems.org/gems/Platform and http://rubygems.org/gems/platform are different gems
3 # if you're seeking for "platform", then package it as ruby-rails-platform!
4 %define gem_name        Platform
5 Summary:        Naive platform detection for Ruby
6 Name:           ruby-platform
7 Version:        0.4.0
8 Release:        2
9 License:        LGPL v2+
10 Group:          Development/Languages
11 Source0:        http://rubygems.org/downloads/%{gem_name}-%{version}.gem
12 # Source0-md5:  9947ef2e902de65ffff3cd5912269678
13 URL:            http://rubyforge.org/projects/platform/
14 BuildRequires:  rpm-rubyprov
15 BuildRequires:  rpmbuild(macros) >= 1.656
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Platform is a library which figures out what platform Ruby is running
21 on. It's doing the obvious thing of parsing RUBY_PLATFORM but doing it
22 systematically and it is being tested to make sure it handles 99% of
23 cases right.
24
25 %prep
26 %setup -q -n %{gem_name}-%{version}
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
31 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
32
33 %clean
34 rm -rf $RPM_BUILD_ROOT
35
36 %files
37 %defattr(644,root,root,755)
38 %doc README
39 %{ruby_vendorlibdir}/platform.rb
This page took 0.166915 seconds and 3 git commands to generate.