]> git.pld-linux.org Git - SPECS.git/blob - ruby-mount.spec
SPECS updated Sat 31 Jul 20:27:02 CEST 2021
[SPECS.git] / ruby-mount.spec
1 Summary:        Mount filesystems in Ruby
2 Summary(pl.UTF-8):      Montowanie systemów plików w języku Ruby
3 Name:           ruby-mount
4 Version:        0.2.1
5 Release:        2
6 License:        GPL
7 Group:          Development/Libraries
8 Source0:        http://theinternetco.net/projects/ruby/%{name}-%{version}.tar.gz
9 # Source0-md5:  1520432391b21890ebc19206e777ff16
10 URL:            http://theinternetco.net/projects/ruby/
11 BuildRequires:  rpmbuild(macros) >= 1.277
12 BuildRequires:  ruby-modules
13 %{?ruby_mod_ver_requires_eq}
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Ruby interface to the Linux mount(2) call.
18
19 %description -l pl.UTF-8
20 Interfejs języka Ruby do linuksowego wywołania mount(2).
21
22 %prep
23 %setup -q
24
25 %build
26 ruby extconf.rb
27 %{__make} \
28         CC="%{__cc}" \
29         CFLAGS="%{rpmcflags} -fPIC"
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT{%{ruby_sitearchdir},%{_examplesdir}/%{name}-%{version}}
34
35 %{__make} install \
36         archdir=$RPM_BUILD_ROOT%{ruby_archdir} \
37         sitearchdir=$RPM_BUILD_ROOT%{ruby_archdir}
38
39 rdoc -o rdoc ext/*
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc rdoc/*
47 %attr(755,root,root) %{ruby_archdir}/linux_mount.so
This page took 0.028872 seconds and 3 git commands to generate.