]> git.pld-linux.org Git - SPECS.git/blob - ruby-mail.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / ruby-mail.spec
1 %define pkgname mail
2 Summary:        A Really Ruby Mail Library
3 Name:           ruby-%{pkgname}
4 Version:        2.6.4
5 Release:        1
6 License:        BSD-like
7 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
8 # Source0-md5:  3e43923308949f33f7281e88c92dc101
9 Group:          Development/Languages
10 URL:            http://github.com/mikel/mail
11 BuildRequires:  rpm-rubyprov
12 BuildRequires:  rpmbuild(macros) >= 1.665
13 %if %(locale -a | grep -q '^en_US$'; echo $?)
14 BuildRequires:  glibc-localedb-all
15 %endif
16 Requires:       ruby-activesupport >= 2.3.4
17 Requires:       ruby-mime-types
18 Requires:       ruby-treetop
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 A Really Ruby Mail Library.
24
25 %package rdoc
26 Summary:        HTML documentation for %{pkgname}
27 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
28 Group:          Documentation
29 Requires:       ruby >= 1:1.8.7-4
30
31 %description rdoc
32 HTML documentation for %{pkgname}.
33
34 %description rdoc -l pl.UTF-8
35 Dokumentacja w formacie HTML dla %{pkgname}.
36
37 %package ri
38 Summary:        ri documentation for %{pkgname}
39 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
40 Group:          Documentation
41 Requires:       ruby
42
43 %description ri
44 ri documentation for %{pkgname}.
45
46 %description ri -l pl.UTF-8
47 Dokumentacji w formacie ri dla %{pkgname}.
48
49 %prep
50 %setup -q -n %{pkgname}-%{version}
51
52 %build
53 # write .gemspec
54 %__gem_helper spec
55
56 # UTF8 locale needed for doc generation
57 export LC_ALL=en_US.UTF-8
58 rdoc --ri --op ri lib
59 rdoc --op rdoc lib
60 rm ri/created.rid
61 rm ri/cache.ri
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_ridir},%{ruby_rdocdir}}
66 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
67 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
68 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
69
70 # install gemspec
71 install -d $RPM_BUILD_ROOT%{ruby_specdir}
72 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc CHANGELOG.rdoc README.md TODO.rdoc
80 %{ruby_vendorlibdir}/mail
81 %{ruby_vendorlibdir}/mail.rb
82 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
83
84 %files rdoc
85 %defattr(644,root,root,755)
86 %{ruby_rdocdir}/%{name}-%{version}
87
88 %files ri
89 %defattr(644,root,root,755)
90 %{ruby_ridir}/Mail
This page took 0.266367 seconds and 3 git commands to generate.