]> git.pld-linux.org Git - SPECS.git/blob - ruby-facade.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / ruby-facade.spec
1 #
2 %define tarname facade
3 Summary:        Facade pattern implementation for Ruby
4 Name:           ruby-facade
5 Version:        1.0.2
6 Release:        1
7 License:        Ruby-alike
8 Group:          Development/Languages
9 Source0:        http://rubyforge.org/frs/download.php/21619/facade-%{version}.tar.bz2
10 # Source0-md5:  f8fb38d2e2c891c87a143c215d2960f0
11 URL:            http://shards.rubyforge.org/
12 BuildRequires:  rpmbuild(macros) >= 1.277
13 BuildRequires:  ruby-modules
14 %{?ruby_mod_ver_requires_eq}
15 #BuildArch:     noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 An easy way to implement the facade pattern in your classes. In short,
20 this library autowraps class methods from another class as instance
21 methods of the current class.
22
23 %prep
24 %setup -q -n %{tarname}-%{version}
25
26 %build
27 rdoc --ri --op ri lib
28 rdoc --op rdoc lib
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir}}
33 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
34 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
35
36 %clean
37 rm -rf $RPM_BUILD_ROOT
38
39 %files
40 %defattr(644,root,root,755)
41 %doc rdoc README
42 %{ruby_rubylibdir}/*
43 %{ruby_ridir}/Facade*
This page took 0.117617 seconds and 3 git commands to generate.