]> git.pld-linux.org Git - SPECS.git/blob - ruby-cocoapods.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / ruby-cocoapods.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname cocoapods
6 Summary:        The Cocoa library package manager
7 Name:           ruby-%{pkgname}
8 Version:        0.39.0
9 Release:        0.1
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  cb8e12483492ead3c580837c89fbf195
14 URL:            https://github.com/CocoaPods/CocoaPods
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 BuildRequires:  sed >= 4.0
18 %if %{with tests}
19 BuildRequires:  ruby-bacon < 2
20 BuildRequires:  ruby-bacon >= 1.1
21 BuildRequires:  ruby-bundler < 2
22 BuildRequires:  ruby-bundler >= 1.3
23 BuildRequires:  ruby-rake < 11
24 BuildRequires:  ruby-rake >= 10.0
25 %endif
26 Requires:       ruby-activesupport >= 4.0.2
27 Requires:       ruby-claide < 0.10
28 Requires:       ruby-claide >= 0.9.1
29 Requires:       ruby-cocoapods-core = 0.39.0
30 Requires:       ruby-cocoapods-downloader < 0.10
31 Requires:       ruby-cocoapods-downloader >= 0.9.3
32 Requires:       ruby-cocoapods-plugins < 0.5
33 Requires:       ruby-cocoapods-plugins >= 0.4.2
34 Requires:       ruby-cocoapods-search < 0.2
35 Requires:       ruby-cocoapods-search >= 0.1.0
36 Requires:       ruby-cocoapods-stats < 0.7
37 Requires:       ruby-cocoapods-stats >= 0.6.2
38 Requires:       ruby-cocoapods-trunk < 0.7
39 Requires:       ruby-cocoapods-trunk >= 0.6.4
40 Requires:       ruby-cocoapods-try < 0.6
41 Requires:       ruby-cocoapods-try >= 0.5.1
42 Requires:       ruby-colored < 2
43 Requires:       ruby-colored >= 1.2
44 Requires:       ruby-escape < 0.1
45 Requires:       ruby-escape >= 0.0.4
46 Requires:       ruby-molinillo < 0.5
47 Requires:       ruby-molinillo >= 0.4.0
48 Requires:       ruby-nap < 2
49 Requires:       ruby-nap >= 1.0
50 Requires:       ruby-xcodeproj < 0.29
51 Requires:       ruby-xcodeproj >= 0.28.2
52 BuildArch:      noarch
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 CocoaPods manages library dependencies for your Xcode project. You
57 specify the dependencies for your project in one easy text file.
58 CocoaPods resolves dependencies between libraries, fetches source code
59 for the dependencies, and creates and maintains an Xcode workspace to
60 build your project. Ultimately, the goal is to improve discoverability
61 of, and engagement in, third party open-source libraries, by creating
62 a more centralized ecosystem.
63
64 %prep
65 %setup -q -n %{pkgname}-%{version}
66 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
67
68 %build
69 # write .gemspec
70 %__gem_helper spec
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir}}
75 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
76 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
77 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_bindir}/pod
85 %attr(755,root,root) %{_bindir}/sandbox-pod
86 %{ruby_vendorlibdir}/%{pkgname}.rb
87 %{ruby_vendorlibdir}/%{pkgname}
88 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.542464 seconds and 3 git commands to generate.