]> git.pld-linux.org Git - SPECS.git/blob - ruby-ajp.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / ruby-ajp.spec
1 %define pkgname ajp
2 Summary:        Apache Jserv Protocol (AJP 1.3) client library for Ruby
3 Name:           ruby-%{pkgname}
4 Version:        0.2.1
5 Release:        0.1
6 License:        LGPL
7 #Source0:       http://rubyforge.org/frs/download.php/18699/%{pkgname}-%{version}.tgz
8 Source0:        http://rubyforge.org/frs/download.php/8309/%{name}-%{version}.gem
9 # Source0-md5:  6b2c82dbe000b25a06c4b408ff90ffa1
10 Group:          Development/Languages
11 URL:            http://rubyforge.org/projects/ruby-ajp/
12 BuildRequires:  rpmbuild(macros) >= 1.484
13 BuildRequires:  ruby >= 1:1.8.6
14 BuildRequires:  ruby-modules
15 BuildRequires:  setup.rb
16 %{?ruby_mod_ver_requires_eq}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 # nothing to be placed there. we're not noarch only because of ruby packaging
20 %define         _enable_debug_packages  0
21
22 %description
23 An implementation of AJP1.3(Apache Jserv Protocol 1.3) in Ruby.
24
25 %package rdoc
26 Summary:        HTML documentation for %{pkgname}
27 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
28 Group:          Documentation
29 Requires:       ruby >= 1:1.8.7-4
30
31 %description rdoc
32 HTML documentation for %{pkgname}.
33
34 %description rdoc -l pl.UTF-8
35 Dokumentacja w formacie HTML dla %{pkgname}.
36
37 %package ri
38 Summary:        ri documentation for %{pkgname}
39 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
40 Group:          Documentation
41 Requires:       ruby
42
43 %description ri
44 ri documentation for %{pkgname}.
45
46 %description ri -l pl.UTF-8
47 Dokumentacji w formacie ri dla %{pkgname}.
48
49 %prep
50 # gem install
51 %setup -q -c
52
53 # gem install
54 %{__tar} xf %{SOURCE0} -O data.tar.gz | %{__tar} xz
55 #find -newer README -o -print | xargs touch --reference %{SOURCE0}
56
57 # cleanup backups after patching
58 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
59
60 %build
61
62 cp %{_datadir}/setup.rb .
63
64 ruby setup.rb config \
65         --rbdir=%{ruby_rubylibdir} \
66         --sodir=%{ruby_archdir}
67
68 ruby setup.rb setup
69
70 rdoc --ri --op ri lib
71 rdoc --op rdoc lib
72 # rm -r ri/NOT_THIS_MODULE_RELATED_DIRS
73 rm ri/created.rid
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir},%{ruby_rdocdir}}
78
79 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
80 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
81
82 ruby setup.rb install \
83         --prefix=$RPM_BUILD_ROOT
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %{ruby_rubylibdir}/net/ajp13.rb
91 %{ruby_rubylibdir}/net/ajp13
92
93 %files rdoc
94 %defattr(644,root,root,755)
95 %{ruby_rdocdir}/%{name}-%{version}
96
97 %files ri
98 %defattr(644,root,root,755)
99 %{ruby_ridir}/Net/AJP13
This page took 0.40146 seconds and 3 git commands to generate.