]> git.pld-linux.org Git - SPECS.git/blob - ruby-activesupport2.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / ruby-activesupport2.spec
1 %define pkgname activesupport
2 Summary:        Utility libraries for Ruby on Rails
3 Name:           ruby-activesupport2
4 Version:        2.3.16
5 Release:        3
6 License:        Ruby-alike
7 Group:          Development/Languages
8 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
9 # Source0-md5:  e8110faabd5f937191585fb1b2986b17
10 Patch0:         ruby-activesupport-nogems.patch
11 URL:            http://rubyforge.org/projects/activesupport/
12 BuildRequires:  rpmbuild(macros) >= 1.277
13 BuildRequires:  ruby >= 1:1.8.6
14 BuildRequires:  ruby-modules
15 %{?ruby_mod_ver_requires_eq}
16 Requires:       ruby-builder >= 2.1.2
17 Requires:       ruby-i18n
18 Requires:       ruby-iconv
19 Requires:       ruby-json
20 Requires:       ruby-mocha >= 0.9.7
21 Requires:       ruby-memcache-client
22 Requires:       ruby-nokogiri >= 1.1.1
23 Requires:       ruby-tzinfo
24 Obsoletes:      ruby-ActiveSupport
25 Provides:       ruby-ActiveSupport
26 Provides:       ruby-activesupport = %{version}
27 #BuildArch:     noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 # nothing to be placed there. we're not noarch only because of ruby packaging
31 %define         _enable_debug_packages  0
32
33 %description
34 Utility libraries for Ruby on Rails.
35
36 %description -l pl.UTF-8
37 Biblioteki narzÄ™dziowe dla Ruby on Rails.
38
39 %package rdoc
40 Summary:        HTML documentation for %{pkgname}
41 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
42 Group:          Documentation
43 Requires:       ruby >= 1:1.8.7-4
44
45 %description rdoc
46 HTML documentation for %{pkgname}.
47
48 %description rdoc -l pl.UTF-8
49 Dokumentacja w formacie HTML dla %{pkgname}.
50
51 %package ri
52 Summary:        ri documentation for %{pkgname}
53 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
54 Group:          Documentation
55 Requires:       ruby
56
57 %description ri
58 ri documentation for %{pkgname}.
59
60 %description ri -l pl.UTF-8
61 Dokumentacji w formacie ri dla %{pkgname}.
62
63 %prep
64 %setup -q -c
65 %{__tar} xf %{SOURCE0} -O data.tar.gz | %{__tar} xz
66 find -newer README  -o -print | xargs touch --reference %{SOURCE0}
67 %patch0 -p1
68
69 %{__rm} -r lib/active_support/vendor*
70
71 # JRuby crap
72 rm lib/active_support/xml_mini/jdom.rb
73
74 %build
75 rdoc --ri --op ri lib
76 rdoc --op rdoc lib
77 rm ri/created.rid
78 rm -fr ri/{CGI,Class,ClassInheritableAttributes,Date,DateTime} \
79         ri/{Enumerable,Exception,FalseClass,File,Float,Hash} \
80         ri/{HashWithIndifferentAccess,Integer,Kernel,Logger} \
81         ri/{LibXML,MissingSourceFile,Module,NameError,NilClass,Numeric} \
82         ri/{Object,Pathname,Proc,Range,Regexp,REXML,String} \
83         ri/{Symbol,Test,Time,TrueClass,Process,Array,BigDecimal} \
84         ri/{Benchmark,ERB,Fixnum,InstanceExecMethods}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir},%{ruby_rdocdir}}
89
90 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
91 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
92 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{pkgname}-%{version}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc CHANGELOG
100 %{ruby_rubylibdir}/active_support
101 %{ruby_rubylibdir}/active_support.rb
102 %{ruby_rubylibdir}/activesupport.rb
103
104 %files rdoc
105 %defattr(644,root,root,755)
106 %{ruby_rdocdir}/%{pkgname}-%{version}
107
108 %files ri
109 %defattr(644,root,root,755)
110 %{ruby_ridir}/ActiveSupport
This page took 0.237241 seconds and 3 git commands to generate.