]> git.pld-linux.org Git - SPECS.git/blob - riemann-c-client.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / riemann-c-client.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 Summary:        Riemann client library
6 Summary(pl.UTF-8):      Biblioteka kliencka Riemann
7 Name:           riemann-c-client
8 Version:        1.10.4
9 Release:        1
10 License:        LGPL v3+
11 Group:          Libraries
12 #Source0Download: https://github.com/algernon/riemann-c-client/releases
13 Source0:        https://github.com/algernon/riemann-c-client/archive/%{name}-%{version}.tar.gz
14 # Source0-md5:  716a0385233b8fbcff13de1a5b4cea10
15 Patch0:         %{name}-dep.patch
16 URL:            https://github.com/algernon/riemann-c-client
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  check-devel
20 BuildRequires:  gnutls-devel >= 2.8
21 BuildRequires:  json-c-devel >= 0.11
22 BuildRequires:  libtool >= 2:2
23 BuildRequires:  pkgconfig
24 BuildRequires:  protobuf-c-devel
25 Requires:       json-c >= 0.11
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This is a C client library for the Riemann monitoring system,
30 providing a convenient and simple API, high test coverage and a
31 copyleft license, along with API and ABI stability.
32
33 %description -l pl.UTF-8
34 Ten pakiet zawiera przeznaczoną dla języka C bibliotekę kliencką
35 systemu monitorowania Riemann, udostępniającą wygodne i proste API,
36 mającą duże pokrycie testami oraz licencję typu copyleft, a także
37 stabilne API i ABI.
38
39 %package devel
40 Summary:        Header files for riemann-client library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki riemann-client
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       protobuf-c-devel
45
46 %description devel
47 Header files for riemann-client library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki riemann-client.
51
52 %package static
53 Summary:        Static riemann-client library
54 Summary(pl.UTF-8):      Statyczna biblioteka riemann-client
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static riemann-client library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka riemann-client.
63
64 %prep
65 %setup -q -n %{name}-%{name}-%{version}
66 %patch0 -p1
67
68 %build
69 %{__libtoolize}
70 %{__aclocal}
71 %{__autoconf}
72 %{__autoheader}
73 %{__automake}
74 %configure \
75         --disable-silent-rules \
76         %{!?with_static_libs:--disable-static}
77
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libriemann-client.la
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc NEWS.md README.md
97 %attr(755,root,root) %{_bindir}/riemann-client
98 %attr(755,root,root) %{_libdir}/libriemann-client.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/libriemann-client.so.0
100 %{_mandir}/man1/riemann-client.1*
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libriemann-client.so
105 %{_includedir}/riemann
106 %{_pkgconfigdir}/riemann-client.pc
107
108 %if %{with static_libs}
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/libriemann-client.a
112 %endif
This page took 0.223467 seconds and 3 git commands to generate.