]> git.pld-linux.org Git - SPECS.git/blob - raplcap.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / raplcap.spec
1 Summary:        C interface for getting/setting power caps with Intel RAPL
2 Summary(pl.UTF-8):      Interfejs C do odczytu/zapisu ograniczeń energii przy użyciu Intel RAPL
3 Name:           raplcap
4 Version:        0.5.0
5 Release:        1
6 License:        BSD
7 Group:          Applications/System
8 #Source0Download: https://github.com/powercap/raplcap/releases
9 Source0:        https://github.com/powercap/raplcap/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  1f8f6a5435e3311fe9f3b1678317f4aa
11 URL:            https://github.com/powercap/raplcap
12 BuildRequires:  cmake >= 2.8.12
13 BuildRequires:  pkgconfig
14 BuildRequires:  powercap-devel >= 0.3.0
15 Requires:       powercap >= 0.3.0
16 # so far only Intel CPUs are supported
17 ExclusiveArch:  i686 pentium4 x86_64 ia32e x32
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This project provides the powercap library - a generic C interface to
22 the Linux power capping framework (sysfs interface). It includes an
23 implementation for working with Intel Running Average Power Limit
24 (RAPL).
25
26 %description -l pl.UTF-8
27 Ten projekt dostarcza bibliotekę powercap - ogólny interfejs C do
28 szkieletu Linuksa ograniczającego zużycie energii (przez interfejs
29 sysfs). Zawiera implementację działającą z Intel RAPL (Running Average
30 Power Limit).
31
32 %package devel
33 Summary:        Header files for raplcap libraries
34 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek raplcap
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       powercap-devel >= 0.3.0
38
39 %description devel
40 Header files for raplcap libraries.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe bibliotek raplcap.
44
45 %prep
46 %setup -q
47
48 %build
49 install -d build
50 cd build
51 # .pc file generation expects relative CMAKE_INSTALL_{INCLUDE,LIB}DIR
52 %cmake .. \
53         -DCMAKE_INSTALL_INCLUDEDIR=include \
54         -DCMAKE_INSTALL_LIBDIR=%{_lib}
55
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} -C build install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post   -p /sbin/ldconfig
68 %postun -p /sbin/ldconfig
69
70 %files
71 %defattr(644,root,root,755)
72 %doc AUTHORS LICENSE README.md RELEASES.md
73 %attr(755,root,root) %{_bindir}/rapl-configure-msr
74 %attr(755,root,root) %{_bindir}/rapl-configure-powercap
75 %attr(755,root,root) %{_libdir}/libraplcap-msr.so.*.*.*
76 %attr(755,root,root) %ghost %{_libdir}/libraplcap-msr.so.0
77 %attr(755,root,root) %{_libdir}/libraplcap-powercap.so.*.*.*
78 %attr(755,root,root) %ghost %{_libdir}/libraplcap-powercap.so.0
79 %{_mandir}/man1/rapl-configure-msr.1*
80 %{_mandir}/man1/rapl-configure-powercap.1*
81
82 %files devel
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_libdir}/libraplcap-msr.so
85 %attr(755,root,root) %{_libdir}/libraplcap-powercap.so
86 %{_includedir}/raplcap
87 %{_pkgconfigdir}/raplcap-msr.pc
88 %{_pkgconfigdir}/raplcap-powercap.pc
This page took 0.500893 seconds and 3 git commands to generate.