]> git.pld-linux.org Git - SPECS.git/blob - radare.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / radare.spec
1 #
2 %bcond_without  doc             # build without documentation
3 #
4 Summary:                Advanced commandline hexadecimal editor
5 Summary(pl.UTF-8):      Zaawansowany edytor szesnastkowy obsługiwany z linii poleceń
6 Name:                   radare
7 Version:                1.0
8 Release:                0.1
9 License:                GPL
10 Group:                  Applications
11 Source0:                http://radare.nopcode.org/get/%{name}-%{version}.tar.gz
12 # Source0-md5:  0e4b2f114fee364c0a7c60de81b5ccb9
13 %if %{with doc}
14 Source1:                http://radare.nopcode.org/get/%{name}.pdf
15 # Source1-md5:  cb8ccb676e859680467ec6e058738a50
16 %endif
17 Patch0:                 %{name}-lua51.patch
18 URL:                    http://radare.nopcode.org/
19 BuildRequires:  gtkdialog
20 BuildRequires:  readline-devel
21 BuildRequires:  vala >= 0.3.4
22 BuildRequires:  lua51-devel
23 BuildRequires:  libewf-devel
24 BuildRequires:  libusb-devel
25 BuildRequires:  vte-devel
26 Suggests:               python
27 Suggests:               ruby
28 BuildRoot:              %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The project aims to create a complete free *nix-like toolchain for working with binary files.
32
33 Its core is a commandline block-based hexadecimal editor which handles everything as a file.
34 A process, file, disk, memory... This flexibility offers nice scripting features which can
35 be mixed with Lua, Lisp, Perl, Python and Vala.
36
37 %description -l pl.UTF-8
38 Celem projektu jest stworzenie kompletnego i darmowego zestawu narzędzi do pracy z plikami
39 binarnymi.
40
41 Rdzeniem jest blokowy edytor szesnastkowy obsługiwany z linii poleceń, który obsługuje
42 wszystkie rodzaje danych jak pliki. Procesy, pliki, dyski, pamięć... Ta elastyczność
43 pozwala na łatwe tworzenie skryptów w językach takich jak Lua, Lisp, Perl, Vala.
44
45 %if %{with doc}
46 %package doc
47 Summary:        Documentation for radare
48 Summary(pl.UTF-8):      Dokumentacja dla radare
49 Group:                  Applications
50
51 %description doc
52 Documentation for radare.
53
54 %description doc -l pl.UTF-8
55 Dokuemntacja dla radare.
56 %endif
57
58 %prep
59 %setup -q
60 %patch0 -p1
61
62 %build
63 # Won't link with --as-needed flag, so we run plain ./configure here
64 LUA=/usr/bin/lua51 \
65 ./configure --prefix=/usr --exec-prefix=/usr
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 # create directories if necessary
71 #install -d $RPM_BUILD_ROOT
72 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 mv $RPM_BUILD_ROOT%{_docdir}/%{name} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
78 mv $RPM_BUILD_ROOT/usr/man $RPM_BUILD_ROOT%{_mandir}
79 %if %{with doc}
80 install -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/
81 %endif
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %attr(755,root,root) %{_bindir}/*
89 %{_libdir}/libfdsniff.so
90 %{_libdir}/libusbsniff.so
91 %{_libdir}/%{name}
92 %{_datadir}/%{name}
93 %{_mandir}/man1/*
94
95 %files doc
96 %defattr(644,root,root,755)
97 %doc %{_docdir}/%{name}-%{version}
This page took 0.112388 seconds and 3 git commands to generate.