]> git.pld-linux.org Git - SPECS.git/blob - qtorrent.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / qtorrent.spec
1 Summary:        A PyQt GUI for BitTorrent
2 Summary(pl.UTF-8):      Interfejs GUI do BitTorrenta
3 Name:           qtorrent
4 Version:        2.9.3
5 Release:        1
6 License:        MIT
7 Group:          Applications/Networking
8 Source0:        http://thegraveyard.org/files/%{name}-%{version}.tar.bz2
9 # Source0-md5:  c8f516416a1582beecf5011f8157e130
10 Patch0:         %{name}-setup.patch
11 URL:            http://thegraveyard.org/qtorrent.php
12 BuildRequires:  python >= 1:2.5
13 BuildRequires:  python-PyQt
14 BuildRequires:  python-devel >= 1:2.5
15 BuildRequires:  python-modules >= 1:2.5
16 BuildRequires:  rpm-pythonprov
17 %pyrequires_eq  python-libs
18 Requires:       python-PyQt
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 QTorrent is a BitTorrent client that uses the Qt widget-set. It allows
24 you to have several torrents open at the same time from within the
25 same program window, offering you easy overview, access and management
26 through a list-mode. Every torrent also has it's own page where you
27 can control things like upload speed and upload slots. A page that
28 shows some statistics of all open torrents is also available.
29
30 %description -l pl.UTF-8
31 QTorrent jest klientem BitTorrenta używającym widgetów Qt. Pozwala na
32 otwarcie kilku torrentów jednocześnie w jednym oknie programu. Oferuje
33 łatwy podgląd, dostęp i zarządzanie przez listę. Każdy potok
34 ("torrent") ma także własną stronę przez która można kontrolować
35 szybkość uploadu i sloty. Strona też przedstawia pewne statystyki
36 wszystkich otwartych potoków.
37
38 %prep
39 %setup -q
40 %patch0 -p1
41
42 %build
43 %{__python} setup.py build
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__python} setup.py install \
49         --optimize=2 \
50         --root $RPM_BUILD_ROOT
51
52 # Remove *.py files. We don't package them.
53 find $RPM_BUILD_ROOT%{py_sitescriptdir}/pyqtorrent3 -type f -name '*.py' -print0 | xargs -0 rm -f
54
55 # add a symlink: qtorrent.py -> qtorrent
56 ln -fs %{_bindir}/qtorrent.py $RPM_BUILD_ROOT%{_bindir}/%{name}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc LICENSE.txt MANIFEST PKG-INFO
64 %attr(755,root,root) %{_bindir}/qtorrent.py
65 %attr(755,root,root) %ghost %{_bindir}/qtorrent
66 %dir %{py_sitescriptdir}/pyqtorrent3
67 %dir %{py_sitescriptdir}/pyqtorrent3/BitTorrent
68 %dir %{py_sitescriptdir}/pyqtorrent3/QtGui
69 %dir %{py_sitescriptdir}/pyqtorrent3/WebGui
70 %dir %{py_sitescriptdir}/pyqtorrent3/WebGui/templates
71 %{py_sitescriptdir}/pyqtorrent3/*.py[co]
72 %{py_sitescriptdir}/pyqtorrent3/BitTorrent/*.py[co]
73 %{py_sitescriptdir}/pyqtorrent3/QtGui/*.py[co]
74 %{py_sitescriptdir}/pyqtorrent3/WebGui/*.py[co]
75 %{py_sitescriptdir}/pyqtorrent3/WebGui/templates/*.html
76 %{py_sitescriptdir}/%{name}-%{version}-py*.egg-info
This page took 0.084856 seconds and 3 git commands to generate.