]> git.pld-linux.org Git - SPECS.git/blob - qt5-qtsvg.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / qt5-qtsvg.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Documentation
4
5 %define         orgname         qtsvg
6 %define         qtbase_ver      %{version}
7 %define         qttools_ver     %{version}
8 Summary:        The Qt5 Svg library
9 Summary(pl.UTF-8):      Biblioteka Qt5 Svg
10 Name:           qt5-%{orgname}
11 Version:        5.15.2
12 Release:        2
13 License:        LGPL v3 or GPL v2 or GPL v3 or comercial
14 Group:          X11/Libraries
15 Source0:        http://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
16 # Source0-md5:  c0f5c1c2cc1b66e56ce4ef13a2b7093a
17 URL:            https://www.qt.io/
18 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
19 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
20 BuildRequires:  Qt5Widgets-devel >= %{qtbase_ver}
21 # for examples
22 BuildRequires:  Qt5OpenGL-devel >= %{qtbase_ver}
23 # for tests
24 BuildRequires:  Qt5Xml-devel >= %{qtbase_ver}
25 %if %{with doc}
26 BuildRequires:  qt5-assistant >= %{qttools_ver}
27 %endif
28 BuildRequires:  qt5-build >= %{qtbase_ver}
29 BuildRequires:  qt5-qmake >= %{qtbase_ver}
30 BuildRequires:  rpmbuild(macros) >= 1.752
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 BuildRequires:  zlib-devel
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         specflags       -fno-strict-aliasing
37 %define         qt5dir          %{_libdir}/qt5
38
39 %description
40 Qt is a cross-platform application and UI framework. Using Qt, you can
41 write web-enabled applications once and deploy them across desktop,
42 mobile and embedded systems without rewriting the source code.
43
44 This package contains Qt5 Svg library.
45
46 %description -l pl.UTF-8
47 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
48 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
49 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
50 źródłowego.
51
52 Ten pakiet zawiera bibliotekę Qt5 Svg.
53
54 %package -n Qt5Svg
55 Summary:        The Qt5 Svg library
56 Summary(pl.UTF-8):      Biblioteka Qt5 Svg
57 Group:          Libraries
58 Requires:       Qt5Core >= %{qtbase_ver}
59 Requires:       Qt5Gui >= %{qtbase_ver}
60 Requires:       Qt5Widgets >= %{qtbase_ver}
61 Obsoletes:      qt5-qtsvg < 5.3.0
62
63 %description -n Qt5Svg
64 Qt5 Svg library provides functionality for handling SVG images.
65
66 %description -n Qt5Svg -l pl.UTF-8
67 Biblioteka Qt5 Svg udostępnia obsługę obrazów SVG.
68
69 %package -n Qt5Svg-devel
70 Summary:        Qt5 Svg library - development files
71 Summary(pl.UTF-8):      Biblioteka Qt5 Svg - pliki programistyczne
72 Group:          X11/Development/Libraries
73 Requires:       Qt5Core-devel >= %{qtbase_ver}
74 Requires:       Qt5Gui-devel >= %{qtbase_ver}
75 Requires:       Qt5Svg = %{version}-%{release}
76 Requires:       Qt5Widgets-devel >= %{qtbase_ver}
77 Requires:       zlib-devel
78 Obsoletes:      qt5-qtsvg-devel < 5.3.0
79
80 %description -n Qt5Svg-devel
81 Qt5 Svg library - development files.
82
83 %description -n Qt5Svg-devel -l pl.UTF-8
84 Biblioteka Qt5 Svg - pliki programistyczne.
85
86 %package doc
87 Summary:        Qt5 Svg documentation in HTML format
88 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Svg w formacie HTML
89 Group:          Documentation
90 Requires:       qt5-doc-common >= %{qtbase_ver}
91 BuildArch:      noarch
92
93 %description doc
94 Qt5 Svg documentation in HTML format.
95
96 %description doc -l pl.UTF-8
97 Dokumentacja do biblioteki Qt5 Svg w formacie HTML.
98
99 %package doc-qch
100 Summary:        Qt5 Svg documentation in QCH format
101 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Svg w formacie QCH
102 Group:          Documentation
103 Requires:       qt5-doc-common >= %{qtbase_ver}
104 BuildArch:      noarch
105
106 %description doc-qch
107 Qt5 Svg documentation in QCH format.
108
109 %description doc-qch -l pl.UTF-8
110 Dokumentacja do biblioteki Qt5 Svg w formacie QCH.
111
112 %package examples
113 Summary:        Qt5 Svg examples
114 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 Svg
115 Group:          X11/Development/Libraries
116 BuildArch:      noarch
117
118 %description examples
119 Qt5 Svg examples.
120
121 %description examples -l pl.UTF-8
122 Przykłady do biblioteki Qt5 Svg.
123
124 %prep
125 %setup -q -n %{orgname}-everywhere-src-%{version}
126
127 %build
128 qmake-qt5
129 %{__make}
130 %{?with_doc:%{__make} docs}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %{__make} install \
136         INSTALL_ROOT=$RPM_BUILD_ROOT
137
138 %if %{with doc}
139 %{__make} install_docs \
140         INSTALL_ROOT=$RPM_BUILD_ROOT
141 %endif
142
143 # useless symlinks
144 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
145 # actually drop *.la, follow policy of not packaging them when *.pc exist
146 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
147
148 # Prepare some files list
149 ifecho() {
150         r="$RPM_BUILD_ROOT$2"
151         if [ -d "$r" ]; then
152                 echo "%%dir $2" >> $1.files
153         elif [ -x "$r" ] ; then
154                 echo "%%attr(755,root,root) $2" >> $1.files
155         elif [ -f "$r" ]; then
156                 echo "$2" >> $1.files
157         else
158                 echo "Error generation $1 files list!"
159                 echo "$r: no such file or directory!"
160                 return 1
161         fi
162 }
163 ifecho_tree() {
164         ifecho $1 $2
165         for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
166                 ifecho $1 $2/$f
167         done
168 }
169
170 echo "%defattr(644,root,root,755)" > examples.files
171 ifecho_tree examples %{_examplesdir}/qt5/svg
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post   -n Qt5Svg -p /sbin/ldconfig
177 %postun -n Qt5Svg -p /sbin/ldconfig
178
179 %files -n Qt5Svg
180 %defattr(644,root,root,755)
181 %doc dist/changes-*
182 %attr(755,root,root) %{_libdir}/libQt5Svg.so.*.*.*
183 %attr(755,root,root) %ghost %{_libdir}/libQt5Svg.so.5
184 # R: Core Gui Svg
185 %attr(755,root,root) %{qt5dir}/plugins/iconengines/libqsvgicon.so
186 # R: Core Gui Svg
187 %attr(755,root,root) %{qt5dir}/plugins/imageformats/libqsvg.so
188
189 %files -n Qt5Svg-devel
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/libQt5Svg.so
192 %{_libdir}/libQt5Svg.prl
193 %{_includedir}/qt5/QtSvg
194 %{_pkgconfigdir}/Qt5Svg.pc
195 %dir %{_libdir}/cmake/Qt5Svg
196 %{_libdir}/cmake/Qt5Svg/Qt5SvgConfig*.cmake
197 %{_libdir}/cmake/Qt5Gui/Qt5Gui_QSvgIconPlugin.cmake
198 %{_libdir}/cmake/Qt5Gui/Qt5Gui_QSvgPlugin.cmake
199 %{qt5dir}/mkspecs/modules/qt_lib_svg.pri
200 %{qt5dir}/mkspecs/modules/qt_lib_svg_private.pri
201
202 %if %{with doc}
203 %files doc
204 %defattr(644,root,root,755)
205 %{_docdir}/qt5-doc/qtsvg
206
207 %files doc-qch
208 %defattr(644,root,root,755)
209 %{_docdir}/qt5-doc/qtsvg.qch
210 %endif
211
212 %files examples -f examples.files
213 %defattr(644,root,root,755)
214 # XXX: dir shared with qt5-qtbase-examples
215 %dir %{_examplesdir}/qt5
This page took 0.372051 seconds and 3 git commands to generate.