]> git.pld-linux.org Git - SPECS.git/blob - qmidiarp.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / qmidiarp.spec
1 Summary:        Advanced MIDI arpeggiator, programmable step sequencer and LFO
2 Name:           qmidiarp
3 Version:        0.6.5
4 Release:        1
5 License:        GPL v2
6 Group:          Applications
7 Source0:        http://downloads.sourceforge.net/qmidiarp/%{name}-%{version}.tar.bz2
8 # Source0-md5:  f63011900519ed277a4ace95ba19d2ac
9 URL:            http://qmidiarp.sourceforge.net/
10 BuildRequires:  Qt5Core-devel
11 BuildRequires:  Qt5Gui-devel
12 BuildRequires:  Qt5Widgets-devel
13 BuildRequires:  alsa-lib-devel
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  jack-audio-connection-kit-devel
17 BuildRequires:  libtool
18 BuildRequires:  lv2-devel
19 BuildRequires:  qt5-build
20 BuildRequires:  qt5-linguist
21 Requires:       %{name}-common = %{version}-%{release}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _noautoprovfiles        %{_libdir}/lv2
25
26 %description
27 QMidiArp is an advanced MIDI arpeggiator, programmable step sequencer
28 and LFO for Linux. It can hold any number of arpeggiator, sequencer,
29 or LFO modules running in parallel.
30
31 - Arpeggiator modules produce sequences depending on the notes sent to
32   their input port, which is typically connected to a keyboard or
33   another sequencer.
34
35 - Step sequencer modules allow you to create simple linear, monophonic
36   and globally transposable sequences similar to the first analog
37   sequencers.
38
39 - MIDI LFO modules independently produce MIDI controller data of
40   adjustable waveform, time resolution, amplitude and duration.
41
42 - A Global Storage Tool can store different setups and switch between
43   them at a given time. It allows you to dynamically combine patterns
44   and LFO wave forms.
45
46 %package lv2
47 Summary:        QMidiArp (arpeggiator, step sequencer and LFO) LV2 modules
48 Group:          Applications
49 Requires:       %{name}-common = %{version}-%{release}
50
51 %description lv2
52 QMidiArp is an advanced MIDI arpeggiator, programmable step sequencer
53 and LFO for Linux. It can hold any number of arpeggiator, sequencer,
54 or LFO modules running in parallel.
55
56 - Arpeggiator modules produce sequences depending on the notes sent to
57   their input port, which is typically connected to a keyboard or
58   another sequencer.
59
60 - Step sequencer modules allow you to create simple linear, monophonic
61   and globally transposable sequences similar to the first analog
62   sequencers.
63
64 - MIDI LFO modules independently produce MIDI controller data of
65   adjustable waveform, time resolution, amplitude and duration.
66
67 - A Global Storage Tool can store different setups and switch between
68   them at a given time. It allows you to dynamically combine patterns
69   and LFO wave forms.
70
71 %package common
72 Summary:        QMidiArp - common files
73 Group:          Applications
74
75 %description common
76 Common files for QMidiArp standalone application and LV2 modules.
77
78 %prep
79 %setup -q
80
81 %build
82 %{__libtoolize}
83 %{__aclocal}
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87
88 %configure \
89         --disable-nsm
90
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %find_lang %{name} --with-qm
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files
105 %defattr(644,root,root,755)
106 %doc AUTHORS ChangeLog NEWS README
107 %attr(755,root,root) %{_bindir}/qmidiarp
108 %{_desktopdir}/qmidiarp.desktop
109 %{_iconsdir}/hicolor/scalable/apps/qmidiarp.svg
110 %{_datadir}/metainfo/qmidiarp.appdata.xml
111 %{_mandir}/man1/qmidiarp.1*
112 %lang(de) %{_mandir}/de/man1/qmidiarp.1*
113 %lang(fr) %{_mandir}/fr/man1/qmidiarp.1*
114
115 %files common -f %{name}.lang
116 %defattr(644,root,root,755)
117 %dir %{_datadir}/%{name}
118 %{_datadir}/%{name}/examples
119 %dir %{_datadir}/%{name}/translations
120
121 %files lv2
122 %defattr(644,root,root,755)
123 %dir %{_libdir}/lv2/qmidiarp_arp.lv2
124 %{_libdir}/lv2/qmidiarp_arp.lv2/manifest.ttl
125 %attr(755,root,root) %{_libdir}/lv2/qmidiarp_arp.lv2/qmidiarp_arp.so
126 %{_libdir}/lv2/qmidiarp_arp.lv2/qmidiarp_arp.ttl
127 %attr(755,root,root) %{_libdir}/lv2/qmidiarp_arp.lv2/qmidiarp_arp_ui.so
128 %{_libdir}/lv2/qmidiarp_arp.lv2/qmidiarp_arp_ui.ttl
129 %dir %{_libdir}/lv2/qmidiarp_lfo.lv2
130 %{_libdir}/lv2/qmidiarp_lfo.lv2/manifest.ttl
131 %attr(755,root,root) %{_libdir}/lv2/qmidiarp_lfo.lv2/qmidiarp_lfo.so
132 %{_libdir}/lv2/qmidiarp_lfo.lv2/qmidiarp_lfo.ttl
133 %attr(755,root,root) %{_libdir}/lv2/qmidiarp_lfo.lv2/qmidiarp_lfo_ui.so
134 %{_libdir}/lv2/qmidiarp_lfo.lv2/qmidiarp_lfo_ui.ttl
135 %dir %{_libdir}/lv2/qmidiarp_seq.lv2
136 %{_libdir}/lv2/qmidiarp_seq.lv2/manifest.ttl
137 %attr(755,root,root) %{_libdir}/lv2/qmidiarp_seq.lv2/qmidiarp_seq.so
138 %{_libdir}/lv2/qmidiarp_seq.lv2/qmidiarp_seq.ttl
139 %attr(755,root,root) %{_libdir}/lv2/qmidiarp_seq.lv2/qmidiarp_seq_ui.so
140 %{_libdir}/lv2/qmidiarp_seq.lv2/qmidiarp_seq_ui.ttl
This page took 0.13992 seconds and 3 git commands to generate.