]> git.pld-linux.org Git - SPECS.git/blob - qmailadmin.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / qmailadmin.spec
1 Summary:        CGI admin interface to vpopmail
2 Summary(pl.UTF-8):      Interfejs CGI do administrowania vpopmailem
3 Name:           qmailadmin
4 Version:        1.0.6
5 Release:        0.1
6 License:        GPL
7 Group:          Networking/Mail
8 Source0:        http://dl.sourceforge.net/qmailadmin/%{name}-%{version}.tar.gz
9 # Source0-md5:  7a6a4acb4f8a04b4cf5170778713020b
10 #Source1:       README.hooks.bz2
11 #Source2:       %{name}.png
12 URL:            http://inter7.com/qmailadmin.html
13 BuildRequires:  mysql-devel
14 BuildRequires:  vpopmail-devel >= 5.3.3-0.2
15 Requires:       autorespond
16 Requires:       ezmlm-idx
17 Requires:       qmail
18 Requires:       vpopmail
19 Requires:       webserver
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         vuser           vpopmail
23 %define         vgroup          vchkpw
24 %define         vhome           /var/lib/%{vuser}
25 %define         varqmail        /var/qmail
26 %define         httpdir         /home/services/httpd
27 %define         cgidir          /home/services/httpd/cgi-bin
28 %define         htmldir         /home/services/httpd/html
29
30 %description
31 qmailadmin is a CGI software for administering vpopmail domains.
32
33 Every e-mail domain owner can manage its users, forwards,
34 autoresponders and mailinglists without nagging the system owner at
35 all.
36
37 Hooks are included to run external software when the domain owner adds
38 or deletes users, forwards, autoresponders and mailinglists. The main
39 reason you might want this is for billing purposes or just plain
40 logging.
41
42 %description -l pl.UTF-8
43 qmailadmin to program CGI do administrowania domenami vpopmaila.
44
45 Każdy właściciel domeny pocztowej może zarządzać swoimi użytkownikami,
46 przekierowaniami, automatycznymi odpowiedziami i listami dyskusyjnymi
47 bez udziału administratora systemu.
48
49 qmailadmin ma możliwość uruchamiania zewnętrznych programów kiedy
50 właściciel domeny dodaje lub usuwa użytkowników, przekierowania,
51 automatyczne odpowiedzi i listy dyskusyjne. Może to służyć do
52 wystawiania rachunków lub zwykłego logowania.
53
54 %prep
55 %setup -q
56
57 %build
58 #%{__autoconf}
59
60 CFLAGS="%{rpmcflags} -I/usr/include/vpopmail"
61 LIBS="/usr/%{_lib}/libvpopmail.a -lmysqlclient"; export LIBS
62 # don't use -lnsl
63 export ac_cv_lib_nsl_gethostbyaddr=no
64 # don't regenerate, configure has been modified
65 %configure2_13 \
66         --enable-cgibindir=%{cgidir} \
67         --with-htmllibdir=%{_datadir}/%{name} \
68         --enable-htmldir=/images/%{name} \
69         --enable-cgipath=/cgi-bin/%{name}.cgi \
70         --enable-autoresponder-bin=%{_bindir}/autorespond \
71         --enable-vpopuser=%{vuser} \
72         --enable-vpopgroup=%{vgroup} \
73         --enable-qmaildir=%{varqmail} \
74         --enable-ezmlmdir=%{_bindir} \
75         --enable-vpopmaildir=%{vhome} \
76         --enable-maxpopusers=-1 \
77         --enable-maxaliases=-1 \
78         --enable-maxforwards=-1 \
79         --enable-maxautoresponders=-1 \
80         --enable-maxmailinglists=-1 \
81         --enable-maxusersperpage=15 \
82         --enable-maxaliasesperpage=25 \
83         --enable-ezmlmidx=y \
84         --enable-defaultquota=-1 \
85         --enable-no-cache=y
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT{%{htmldir}/images/%{name},%{cgidir}} \
92         $RPM_BUILD_ROOT%{_datadir}/%{name}/html \
93         $RPM_BUILD_ROOT%{_libdir}/%{name}/scripts
94
95 install %{name} $RPM_BUILD_ROOT%{cgidir}/%{name}.cgi
96
97 # install the templates and the language files.
98 install html/* $RPM_BUILD_ROOT%{_datadir}/%{name}/html
99
100 # install the images.
101 install images/* $RPM_BUILD_ROOT%{htmldir}/images/%{name}
102 cp $RPM_BUILD_ROOT%{_datadir}/%{name}/html/en $RPM_BUILD_ROOT%{_datadir}/%{name}/html/en-us
103
104 # install script to call the web interface from the menu.
105 cat <<EOF > $RPM_BUILD_ROOT%{_libdir}/%{name}/scripts/%{name}
106 #!/bin/sh
107 url='http://localhost/cgi-bin/%{name}.cgi'
108 if ! [ -z "\$BROWSER" ] && ( which \$BROWSER ); then
109   browser=\`which \$BROWSER\`
110 elif [ -x %{_bindir}/netscape ]; then
111   browser=%{_bindir}/netscape
112 elif [ -x %{_bindir}/konqueror ]; then
113   browser=%{_bindir}/konqueror
114 elif [ -x %{_bindir}/lynx ]; then
115   browser='xterm -bg black -fg white -e lynx'
116 elif [ -x %{_bindir}/links ]; then
117   browser='xterm -bg black -fg white -e links'
118 else
119   xmessage "No web browser found, install one or set the BROWSER environment variable!"
120   exit 1
121 fi
122 \$browser \$url
123 EOF
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS ChangeLog FAQ INSTALL NEWS README*
131 %attr(6755,%{vuser},%{vgroup}) %{cgidir}/%{name}.cgi
132 %dir %{_datadir}/%{name}
133 %dir %{_datadir}/%{name}/html
134 # XXX: files in _datadir cannot be config
135 %config(noreplace) %{_datadir}/%{name}/html/*
136 %dir %{htmldir}/images
137 %dir %{htmldir}/images/%{name}
138 %config(noreplace) %{htmldir}/images/%{name}/*
139 %dir %{_libdir}/%{name}
140 %dir %{_libdir}/%{name}/scripts
141 %attr(755,root,root) %{_libdir}/%{name}/scripts/%{name}
This page took 2.615675 seconds and 3 git commands to generate.