]> git.pld-linux.org Git - SPECS.git/blob - python3-setuptools_rust.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / python3-setuptools_rust.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (need rust configured)
4 %bcond_with     python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Setuptools plugin to build Rust Python extensions
8 Summary(pl.UTF-8):      Wtyczka setuptools do budowania rozszerzeĹ„ pythonowych Rust
9 Name:           python3-setuptools_rust
10 Version:        0.12.1
11 Release:        1
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/setuptools-rust/
15 Source0:        https://pypi.debian.net/setuptools_rust/setuptools-rust-%{version}.tar.gz
16 # Source0-md5:  33c3fd3bcde2877483ab782353bee54c
17 URL:            https://rusthub.com/msabramo/setuptools-rust
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.5
20 BuildRequires:  python-setuptools
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3-modules >= 1:3.2
24 BuildRequires:  python3-setuptools >= 1:46.0
25 %endif
26 %if %{with tests}
27 BuildRequires:  rust-core
28 %endif
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.714
31 Requires:       python3-modules
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Compile and distribute Python extensions written in Rust as easily as if they were written in C.
37
38 %prep
39 %setup -q -n setuptools-rust-%{version}
40
41 %build
42 %py3_build %{?with_tests:test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %py3_install
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc CHANGELOG.md README.md
55 %{py3_sitescriptdir}/setuptools_rust
56 %{py3_sitescriptdir}/setuptools_rust-%{version}-py*.egg-info
This page took 0.368028 seconds and 3 git commands to generate.