]> git.pld-linux.org Git - SPECS.git/blob - python3-path.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / python3-path.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # py.test unit tests
5
6 Summary:        Python 2 module wrapper for os.path
7 Summary(pl.UTF-8):      Moduł Pythona 2 obudowujący os.path
8 Name:           python3-path
9 Version:        15.1.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.python.org/simple/path/
14 Source0:        https://files.pythonhosted.org/packages/source/p/path/path-%{version}.tar.gz
15 # Source0-md5:  7fa391550400e7aa47849386d99598a7
16 URL:            https://github.com/jaraco/path
17 BuildRequires:  python3 >= 1:3.6
18 BuildRequires:  python3-modules >= 1:3.6
19 BuildRequires:  python3-setuptools >= 1:31.0.1
20 BuildRequires:  python3-setuptools_scm >= 3.4.1
21 BuildRequires:  python3-toml
22 %if %{with tests}
23 BuildRequires:  python3-appdirs
24 BuildRequires:  python3-packaging
25 BuildRequires:  python3-pygments
26 BuildRequires:  python3-pytest >= 3.5
27 BuildRequires:  python3-pytest-black >= 0.3.7
28 BuildRequires:  python3-pytest-cov
29 BuildRequires:  python3-pytest-flake8
30 %endif
31 BuildRequires:  rpm-pythonprov
32 BuildRequires:  rpmbuild(macros) >= 1.714
33 %if %{with doc}
34 BuildRequires:  sphinx-pdg-3
35 BuildRequires:  python3-alabaster
36 BuildRequires:  python3-jaraco.packaging >= 8.2
37 BuildRequires:  python3-rst.linker >= 1.9
38 %endif
39 Requires:       python3-modules >= 1:3.6
40 BuildArch:      noarch
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 path implements a path objects as first-class entities, allowing
45 common operations on files to be invoked on those path objects
46 directly.
47
48 %description -l pl.UTF-8
49 path implementuje obiekty ścieżek jako instancje pierwszoklasowe,
50 pozwalające na wykonywanie ogólnych operacji na plikach bezpośrednio
51 na tych ścieżkach.
52
53 %package apidocs
54 Summary:        Documentation for Python path module
55 Summary(pl.UTF-8):      Dokumentacja modułu Pythona path
56 Group:          Documentation
57
58 %description apidocs
59 Documentation for Python path module.
60
61 %description apidocs -l pl.UTF-8
62 Dokumentacja modułu Pythona path.
63
64 %prep
65 %setup -q -n path-%{version}
66
67 %build
68 %py3_build
69
70 %if %{with tests}
71 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
72 PYTEST_PLUGINS="pytest_black,pytest_cov.plugin,pytest_flake8" \
73 %{__python3} -m pytest test_path.py
74 %endif
75
76 %if %{with doc}
77 # disable warnings (-W in SPHINXOPTS) to ignore objects.inv fetching error on builders
78 %{__make} -C docs html \
79         SPHINXBUILD=sphinx-build-3 \
80         SPHINXOPTS=
81 %endif
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %py3_install
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc CHANGES.rst LICENSE README.rst
94 %{py3_sitescriptdir}/path
95 %{py3_sitescriptdir}/path-%{version}-py*.egg-info
96
97 %if %{with doc}
98 %files apidocs
99 %defattr(644,root,root,755)
100 %doc docs/_build/html/{_static,*.html,*.js}
101 %endif
This page took 0.352823 seconds and 3 git commands to generate.