]> git.pld-linux.org Git - SPECS.git/blob - python3-jupyter_client.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / python3-jupyter_client.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_with     tests   # unit tests (disable for bootstrap: tests need ipykernel which requires jupyter_client; as of 5.3.3 two test_session tests fail)
5
6 Summary:        Reference implementation of the Jupyter protocol
7 Summary(pl.UTF-8):      Referencyjna implementacja protokołu Jupyter
8 Name:           python3-jupyter_client
9 Version:        6.1.7
10 Release:        1
11 License:        BSD
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/jupyter_client/
14 Source0:        https://files.pythonhosted.org/packages/source/j/jupyter_client/jupyter_client-%{version}.tar.gz
15 # Source0-md5:  607468e6039c3fe5566b6d2bc33ac49a
16 Patch0:         %{name}-mock.patch
17 URL:            https://pypi.org/project/jupyter_client/
18 BuildRequires:  python3-modules >= 1:3.5
19 BuildRequires:  python3-setuptools
20 %if %{with tests}
21 BuildRequires:  python3-async_generator
22 BuildRequires:  python3-dateutil >= 2.1
23 BuildRequires:  python3-ipykernel
24 BuildRequires:  python3-ipython
25 BuildRequires:  python3-jupyter_core >= 4.6.0
26 #BuildRequires: python3-msgpack
27 BuildRequires:  python3-pytest
28 BuildRequires:  python3-pytest-asyncio
29 BuildRequires:  python3-pytest-timeout
30 BuildRequires:  python3-traitlets
31 BuildRequires:  python3-tornado >= 4.1
32 BuildRequires:  python3-zmq >= 13
33 %endif
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  rpmbuild(macros) >= 1.714
36 %if %{with doc}
37 #BuildRequires: python3-ipykernel
38 BuildRequires:  python3-sphinx_rtd_theme
39 BuildRequires:  python3-sphinxcontrib_github_alt
40 BuildRequires:  python3-zmq >= 13
41 BuildRequires:  sphinx-pdg-3 >= 1.3.6
42 %endif
43 Requires:       python3-modules >= 1:3.5
44 BuildArch:      noarch
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 jupyter_client contains the reference implementation of the Jupyter
49 protocol. It also provides client and kernel management APIs for
50 working with kernels.
51
52 %description -l pl.UTF-8
53 jupyter_client zawiera referencyjną implementację protokołu Jupyter.
54 Zawiera także API klienckie i zarządzania jądrami.
55
56 %package apidocs
57 Summary:        API documentation for Python jupyter_client module
58 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona jupyter_client
59 Group:          Documentation
60
61 %description apidocs
62 API documentation for Python jupyter_client module.
63
64 %description apidocs -l pl.UTF-8
65 Dokumentacja API modułu Pythona jupyter_client.
66
67 %prep
68 %setup -q -n jupyter_client-%{version}
69 %patch0 -p1
70
71 %build
72 %py3_build %{?with_tests:test}
73
74 %if %{with doc}
75 PYTHONPATH=$(pwd) \
76 %{__make} -C docs html \
77         SPHINXBUILD=sphinx-build-3
78 %endif
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %py3_install
84
85 for f in $RPM_BUILD_ROOT%{_bindir}/jupyter-* ; do
86         %{__mv} "$f" "${f}-3"
87 done
88
89 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/jupyter_client/tests
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(644,root,root,755)
96 %doc COPYING.md README.md
97 %attr(755,root,root) %{_bindir}/jupyter-kernel-3
98 %attr(755,root,root) %{_bindir}/jupyter-kernelspec-3
99 %attr(755,root,root) %{_bindir}/jupyter-run-3
100 %{py3_sitescriptdir}/jupyter_client
101 %{py3_sitescriptdir}/jupyter_client-%{version}-py*.egg-info
102
103 %if %{with doc}
104 %files apidocs
105 %defattr(644,root,root,755)
106 %doc docs/_build/html/{_images,_static,api,*.html,*.js}
107 %endif
This page took 0.379623 seconds and 3 git commands to generate.