]> git.pld-linux.org Git - SPECS.git/blob - python-typogrify.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / python-typogrify.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Filters to enhance web typography, including support for Django & Jinja templates
7 Summary(pl.UTF-8):      Filtry rozszerzające typografię WWW z obsługą szablonów Django i Jinja
8 Name:           python-typogrify
9 Version:        2.0.7
10 Release:        1
11 License:        BSD
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/typogrify/
14 Source0:        https://files.pythonhosted.org/packages/source/t/typogrify/typogrify-%{version}.tar.gz
15 # Source0-md5:  63f38f80531996f187d2894cc497ba08
16 URL:            https://pypi.org/project/typogrify/
17 %if %{with python2}
18 BuildRequires:  python-modules >= 1:2.5
19 BuildRequires:  python-setuptools
20 %endif
21 %if %{with python3}
22 BuildRequires:  python3-modules >= 1:3.2
23 BuildRequires:  python3-setuptools
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 Requires:       python-modules >= 1:2.5
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Typogrify provides a set of custom filters that automatically apply
33 various transformations to plain text in order to yield
34 typographically-improved HTML. While often used in conjunction with
35 Jinja and Django template systems, the filters can be used in any
36 environment.
37
38 %description -l pl.UTF-8
39 Typogrify udostępnia zestaw dostosowanych filtrów, automatycznie
40 nakładających na czysty tekst różne przekształcenia, aby wytworzyć
41 typograficznie ulepszony HTML. Filtry zwykle używane są wraz z
42 systemami szablonów Jinja i Django, ale można ich używać w dowolnym
43 środowisku.
44
45 %package -n python3-typogrify
46 Summary:        Filters to enhance web typography, including support for Django & Jinja templates
47 Summary(pl.UTF-8):      Filtry rozszerzające typografię WWW z obsługą szablonów Django i Jinja
48 Group:          Libraries/Python
49 Requires:       python3-modules >= 1:3.2
50
51 %description -n python3-typogrify
52 Typogrify provides a set of custom filters that automatically apply
53 various transformations to plain text in order to yield
54 typographically-improved HTML. While often used in conjunction with
55 Jinja and Django template systems, the filters can be used in any
56 environment.
57
58 %description -n python3-typogrify -l pl.UTF-8
59 Typogrify udostępnia zestaw dostosowanych filtrów, automatycznie
60 nakładających na czysty tekst różne przekształcenia, aby wytworzyć
61 typograficznie ulepszony HTML. Filtry zwykle używane są wraz z
62 systemami szablonów Jinja i Django, ale można ich używać w dowolnym
63 środowisku.
64
65 %prep
66 %setup -q -n typogrify-%{version}
67
68 %build
69 %if %{with python2}
70 %py_build
71 %endif
72
73 %if %{with python3}
74 %py3_build
75 %endif
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %if %{with python2}
81 %py_install
82
83 %py_postclean
84 %endif
85
86 %if %{with python3}
87 %py3_install
88 %endif
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %if %{with python2}
94 %files
95 %defattr(644,root,root,755)
96 %doc LICENSE.txt README.rst
97 %{py_sitescriptdir}/typogrify
98 %{py_sitescriptdir}/typogrify-%{version}-py*.egg-info
99 %endif
100
101 %if %{with python3}
102 %files -n python3-typogrify
103 %defattr(644,root,root,755)
104 %doc LICENSE.txt README.rst
105 %{py3_sitescriptdir}/typogrify
106 %{py3_sitescriptdir}/typogrify-%{version}-py*.egg-info
107 %endif
This page took 0.21594 seconds and 3 git commands to generate.