]> git.pld-linux.org Git - SPECS.git/blob - python-repoze.lru.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / python-repoze.lru.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  repoze.lru
6 Summary:        A tiny LRU cache implementation and decorator
7 Name:           python-%{module}
8 Version:        0.6
9 Release:        3
10 License:        BSD-derived (http://www.repoze.org/LICENSE.txt)
11 Group:          Libraries/Python
12 Source0:        http://pypi.python.org/packages/source/r/repoze.lru/repoze.lru-%{version}.tar.gz
13 # Source0-md5:  2c3b64b17a8e18b405f55d46173e14dd
14 URL:            http://pypi.python.org/pypi/repoze.lru
15 BuildRequires:  python-distribute
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.710
18 Requires:       python-modules
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 repoze.lru is a LRU (least recently used) cache implementation. Keys
24 and values that are not used frequently will be evicted from the cache
25 faster than keys and values that are used frequently.
26
27 %prep
28 %setup -q -n %{module}-%{version}
29
30 %build
31 %py_build
32
33 %{?with_tests:%{__python} setup.py test}
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 %py_install
38
39 %{__rm} $RPM_BUILD_ROOT%{py_sitescriptdir}/repoze/lru/tests.py*
40
41 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
42 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
43 %py_postclean
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc CHANGES.txt LICENSE.txt README.txt
51 %dir %{py_sitescriptdir}/repoze/
52 %dir %{py_sitescriptdir}/repoze/lru
53 %{py_sitescriptdir}/repoze/lru/*.py[co]
54 %{py_sitescriptdir}/%{module}-%{version}-py*-nspkg.pth
55 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
This page took 0.035272 seconds and 3 git commands to generate.