]> git.pld-linux.org Git - SPECS.git/blob - python-recode.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / python-recode.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # smoke/regression test
4
5 Summary:        Python 2 extension to convert files between character sets
6 Summary(pl.UTF-8):      Rozszerzenie Pythona 2 do konwersji plików między zestawami znaków
7 Name:           python-recode
8 Version:        0.2
9 Release:        1
10 License:        GPL v2+
11 Group:          Libraries/Python
12 #Source0Download: https://github.com/pybliographer/python-recode/releases
13 Source0:        https://github.com/pybliographer/python-recode/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  28e9fc5e0f93c3feb7c5569f5d8b9bf4
15 Patch0:         %{name}-test.patch
16 URL:            https://pypi.org/project/recode/
17 BuildRequires:  python-devel >= 1:2.6
18 BuildRequires:  python-setuptools
19 BuildRequires:  recode-devel >= 3.5
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.714
22 Requires:       python-modules >= 1:2.6
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module contains a simple binding to GNU Recode, a library to
27 convert text and files between character sets.
28
29 %description -l pl.UTF-8
30 Ten moduł zawiera proste wiązanie do GNU Recode - biblioteki do
31 konwersji tekstu i plików między zestawami znaków.
32
33 %prep
34 %setup -q
35 %patch0 -p1
36
37 %build
38 %py_build
39
40 %if %{with tests}
41 PYTHONPATH=$(echo build-2/lib.*) \
42 %{__python} testsuite.py
43 %endif
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %py_install
49
50 %py_postclean
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc NEWS README.rst
58 %attr(755,root,root) %{py_sitedir}/recode.so
59 %{py_sitedir}/python_recode-%{version}-py*.egg-info
This page took 0.23852 seconds and 3 git commands to generate.