]> git.pld-linux.org Git - SPECS.git/blob - python-pypar.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / python-pypar.spec
1
2 %define         module  pypar
3 Summary:        pypar - Parallel Programming in the spirit of Python!
4 Summary(pl.UTF-8):      pypar - programowanie równoległe w duchu Pythona
5 Name:           python-%{module}
6 Version:        1.9.3
7 Release:        10
8 License:        GPL
9 Group:          Libraries/Python
10 Source0:        http://datamining.anu.edu.au/~ole/pypar/%{module}_%{version}.tgz
11 # Source0-md5:  7039dc549acd1db9806e7510c8eb93dc
12 Patch0:         %{name}-build.patch
13 Patch1:         numpy.patch
14 Patch2:         no-m64.patch
15 URL:            http://datamining.anu.edu.au/~ole/pypar/
16 BuildRequires:  rpmbuild(macros) >= 1.710
17 BuildRequires:  mpi-devel
18 BuildRequires:  python-devel >= 1:2.5
19 BuildRequires:  python-numarray-devel
20 BuildRequires:  python-numpy-devel
21 BuildRequires:  rpm-pythonprov
22 %pyrequires_eq  python-libs
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Pypar is an efficient but easy-to-use module that allows
27 programs/scripts written in the Python programming language to run in
28 parallel on multiple processors and communicate using message passing.
29 Pypar provides bindings to an important subset of the message passing
30 interface standard MPI.
31
32 %description -l pl.UTF-8
33 Pypar to sprawny, lecz łatwy w użyciu moduł pozwalający programom i
34 skrtyptom napisanym w języku programowania Python działać równolegle
35 na wielu procesorach i komunikować się przy użyciu przekazywania
36 komunikatów. Pypar udostępnia dowiązania do istotnego podzbioru
37 standardu interfejsu przekazywania komunikatów MPI.
38
39 %package examples
40 Summary:        Example programs for Python pypar module
41 Summary(pl.UTF-8):      Programy przykładowe do modułu Pythona pypar
42 Group:          Development/Languages/Python
43 Requires:       %{name} = %{version}-%{release}
44
45 %description examples
46 This package contains example programs for Python pypar module.
47
48 %description examples -l pl.UTF-8
49 Pakiet zawierający programy przykładowe dla modułu Pythona pypar.
50
51 %prep
52 %setup -q -n %{module}_%{version}
53 %patch0 -p1
54 %patch1 -p1
55 %patch2 -p1
56
57 %build
58 export CFLAGS="%{rpmcflags}"
59 %py_build %{?with_tests:test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
64
65 %py_install
66
67 %py_postclean
68
69 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc DOC FAQ README
77 %dir %{py_sitedir}/%{module}
78 %{py_sitedir}/%{module}/*.py[co]
79 %attr(755,root,root) %{py_sitedir}/%{module}/*.so
80 %{py_sitedir}/*.egg-info
81
82 %files examples
83 %defattr(644,root,root,755)
84 %{_examplesdir}/%{name}-%{version}
This page took 0.247148 seconds and 3 git commands to generate.