]> git.pld-linux.org Git - SPECS.git/blob - python-pylzma.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / python-pylzma.spec
1 %define         module  pylzma
2 Summary:        Platform independent python bindings for the LZMA compression library
3 Name:           python-%{module}
4 Version:        0.3.0
5 Release:        4
6 License:        LGPL v2.1
7 Group:          Libraries/Python
8 Source0:        http://www.joachim-bauch.de/projects/python/pylzma/releases/%{module}-%{version}.tar.gz/download
9 # Source0-md5:  7ab1a1706cf3e19f2d10579d795babf7
10 URL:            http://www.joachim-bauch.de/projects/python/pylzma/
11 BuildRequires:  rpmbuild(macros) >= 1.710
12 BuildRequires:  python >= 1:2.5
13 BuildRequires:  python-devel >= 1:2.5
14 BuildRequires:  python-modules >= 1:2.5
15 BuildRequires:  rpm-pythonprov
16 %pyrequires_eq  python-libs
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Platform independent python bindings for the LZMA compression library.
21
22 Features:
23 - Compression / decompression of a single block of data
24 - Compression from a file-like object (must provide a read method)
25 - Streaming decompression through multiple calls to decompress
26 - An initial library that supports reading of 7-zip archives (both
27   solid and non-solid)
28 - Working on 32-bit Windows and Linux as well as AMD64 on Linux
29 - Multithreaded compression on Windows
30 - Built with 7-zip 4.42
31
32 %prep
33 %setup -q -n %{module}-%{version}
34
35 %build
36 %py_build \
37         --debug
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
42
43 %py_install
44
45 %py_comp $RPM_BUILD_ROOT
46 %py_ocomp $RPM_BUILD_ROOT
47 %py_postclean
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc doc/usage.txt
55 %attr(755,root,root) %{py_sitedir}/*.so
56 %{py_sitedir}/*.py[co]
57 %{py_sitedir}/pylzma-*.egg-info
This page took 0.042516 seconds and 3 git commands to generate.