]> git.pld-linux.org Git - SPECS.git/blob - python-pyao.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / python-pyao.spec
1 %define         module  pyao
2 Summary:        A Python module for the the ao library
3 Summary(pl.UTF-8):      Moduł Pythona do biblioteki ao
4 Name:           python-%{module}
5 Version:        0.82
6 Release:        10
7 License:        GPL
8 Group:          Libraries/Python
9 Source0:        http://ekyo.nerim.net/software/pyogg/%{module}-%{version}.tar.gz
10 # Source0-md5:  8e00f5154401a6f6d99efd20606e2819
11 Patch0:         %{name}-fix.patch
12 URL:            http://ekyo.nerim.net/software/pyogg/
13 BuildRequires:  rpmbuild(macros) >= 1.710
14 BuildRequires:  libao-devel
15 BuildRequires:  python-devel
16 BuildRequires:  python-modules
17 BuildRequires:  rpm-pythonprov
18 Requires:       python-modules
19 Obsoletes:      pyao
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Pyao is a wrapper for libao, an audio device abstraction library.
24
25 %description -l pl.UTF-8
26 Pyao jest wrapperem dla libao - biblioteki abstrakcji do odtwarzania
27 dźwięku.
28
29 %package devel
30 Summary:        pyao header and example programs
31 Summary(pl.UTF-8):      Plik nagłówkowy modułu pyao
32 Group:          Development/Languages/Python
33 Requires:       %{name} = %{version}-%{release}
34 Requires:       libao-devel
35 Obsoletes:      pyao-devel
36
37 %description devel
38 Pyao is a wrapper for libao, an audio device abstraction library. This
39 package contains the header file and example program for pyao.
40
41 %description devel -l pl.UTF-8
42 Pyao jest wrapperem dla libao - biblioteki abstrakcji do odtwarzania
43 dźwięku. Ten pakiet zawiera plik nagłówkowy i przykładowy program dla
44 modułu pyao.
45
46 %prep
47 %setup -q -n %{module}-%{version}
48 %patch0 -p1
49
50 %build
51 python config_unix.py \
52         --prefix %{_prefix}
53 python setup.py config
54 %py_build
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{py_incdir}
59 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %py_install \
62         --root $RPM_BUILD_ROOT
63
64 install src/aomodule.h $RPM_BUILD_ROOT%{py_incdir}
65
66 chmod -x test.py
67 install test.py $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc AUTHORS ChangeLog README
75 %{_examplesdir}/%{name}-%{version}
76 %attr(755,root,root) %{py_sitedir}/*.so
77
78 %files devel
79 %defattr(644,root,root,755)
80 %{py_incdir}/aomodule.h
This page took 0.322941 seconds and 3 git commands to generate.