]> git.pld-linux.org Git - SPECS.git/blob - python-pyAlsa.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / python-pyAlsa.spec
1 %define         module pyAlsa
2
3 Summary:        Python wrapper for alsa-lib
4 Summary(pl.UTF-8):      Moduł alsalib dla Pythona
5 Name:           python-%{module}
6 Version:        0.0.1
7 Release:        5
8 License:        GPL v2
9 Group:          Development/Languages/Python
10 Source0:        http://respyre.org/download/alsamodule-%{version}.tgz
11 # Source0-md5:  ed051ef696d1ea9e71272a6af44e42f9
12 URL:            http://respyre.org/pyalsa.html
13 BuildRequires:  alsa-lib-devel
14 BuildRequires:  python-devel >= 1:2.3
15 BuildRequires:  python-modules
16 BuildRequires:  rpm-pythonprov
17 Requires:       alsa-lib
18 Requires:       python >= 2.3
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 PyAlsa is a Python wrapper for ALSA. For now, it supports ALSA mixers.
23
24 %description -l pl.UTF-8
25 PyAlsa to moduł Pythona dla biblioteki ALSA. Na chwilę obecną
26 obsługuje miksery.
27
28 %prep
29 %setup -q -n alsamodule
30
31 %build
32 %{__make} \
33         CC="%{__cc}" \
34         INCLUDEPY="%{py_incdir}"
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38
39 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{module}}
40
41 cp alsamodule.so $RPM_BUILD_ROOT%{py_sitedir}/
42 cp test.py $RPM_BUILD_ROOT%{_examplesdir}/%{module}/
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc Doc
50 %dir %{_examplesdir}/%{module}
51 %{_examplesdir}/%{module}/*
52 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.947999 seconds and 3 git commands to generate.