]> git.pld-linux.org Git - SPECS.git/blob - python-modplug.spec
SPECS updated Sun 1 Aug 15:50:02 CEST 2021
[SPECS.git] / python-modplug.spec
1 %define         module  modplug
2 Summary:        Python bindings for libmodplug library
3 Summary(pl.UTF-8):      Wiązania języka Python dla biblioteki libmodplug
4 Name:           python-modplug
5 Version:        1.0
6 Release:        1
7 License:        GPLv2
8 Group:          Development/Languages/Python
9 Source0:        http://www.sacredchao.net/~piman/software/%{module}-%{version}.tar.gz
10 # Source0-md5:  a937f97d63fe1dadbe7ca69ae37d77ae
11 URL:            http://www.sacredchao.net/~piman/
12 BuildRequires:  rpmbuild(macros) >= 1.710
13 BuildRequires:  libmodplug-devel >= 0.7
14 BuildRequires:  pkgconfig >= 1:0.21-2
15 BuildRequires:  python-devel
16 BuildRequires:  rpm-pythonprov
17 %pyrequires_eq  python-modules
18 Requires:       libmodplug >= 0.7
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This Python module lets you load and decode files supported by the
23 ModPlug library (which includes MODs, ITs, XMs, and so on). Its API
24 has been chosen to mostly match pyvorbis and pymad.
25
26 Currently it always outputs in 44100kHz stereo, 16 bits per channel.
27 Noise reduction, oversampling, and the highest-quality resampling
28 filter are enabled.
29
30 %description -l pl.UTF-8
31 Ten moduł języka Python pozwala na ładowanie i dekodowanie plików
32 obsługiwanych przez bibliotekę ModPlug (czyli MOD, IT, XM itd.). Jego
33 API zostało stworzone tak, aby jak najbardziej było zbliżone do
34 pyvorbis i pymad.
35
36 Obecnie moduł ten dekoduje do 44100kHz stereo, 16 bitów na kanał.
37 Zawiera także redukcję szumów, oversampling i najwyższej jakości filtr
38 resamplujący.
39
40 %prep
41 %setup -q -n %{module}-%{version}
42 find -type f | xargs sed -i -e 's|#!.*python.*|#!%{_bindir}/python|g'
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
47
48 %py_install
49 install playmod.py $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc README
57 %attr(755,root,root) %{py_sitedir}/*.so
58 %{_examplesdir}/%{name}-%{version}
This page took 0.890768 seconds and 3 git commands to generate.