]> git.pld-linux.org Git - SPECS.git/blob - python-m2ext.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / python-m2ext.spec
1 %define module m2ext
2 Summary:        M2Crypto Extensions
3 Name:           python-m2ext
4 Version:        0.1
5 Release:        4
6 License:        BSD
7 Group:          Development/Languages
8 Source0:        http://pypi.python.org/packages/source/m/%{module}/%{module}-%{version}.tar.gz
9 # Source0-md5:  5b8e448a74a84f8047b8d0713b05bf85
10 URL:            http://pypi.python.org/pypi/m2ext
11 BuildRequires:  openssl-devel
12 BuildRequires:  pkgconfig
13 BuildRequires:  python-M2Crypto
14 BuildRequires:  python-devel
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.710
17 BuildRequires:  swig
18 BuildRequires:  swig-python
19 Requires:       python-M2Crypto
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This package contains some extended functions which are not (yet)
24 available in M2Crypto
25 <http://chandlerproject.org/Projects/MeTooCrypto> trunk.
26
27 %prep
28 %setup -q -n %{module}-%{version}
29
30 %build
31 # The pkgconfig bit was taken from m2crypto.spec
32 # https://apps.fedoraproject.org/packages/m2crypto/sources/spec/
33 CFLAGS="%{rpmcflags}"
34 if pkg-config openssl; then
35         CFLAGS="$CFLAGS $(pkg-config --cflags openssl)"
36         LDFLAGS="$LDFLAGS $(pkg-config --libs-only-L openssl)"
37 fi
38 export CFLAGS LDFLAGS
39
40 CC="%{__cc}" \
41 %py_build
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 %py_install
46
47 %py_postclean
48
49 chmod a+x $RPM_BUILD_ROOT/%{py_sitedir}/%{module}/_m2ext.so
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc README.rst LICENSE
57 %dir %{py_sitedir}/m2ext
58 %{py_sitedir}/m2ext/*.py[co]
59 %attr(755,root,root) %{py_sitedir}/m2ext/_m2ext.so
60 %{py_sitedir}/m2ext-%{version}-py*.egg-info
This page took 0.126919 seconds and 3 git commands to generate.