]> git.pld-linux.org Git - SPECS.git/blob - python-ipaddr.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / python-ipaddr.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 %define         module  ipaddr
6
7 Summary:        Python module is useful to manipulate IP addresses (sets)
8 Summary(pl.UTF-8):      Moduł języka Python do operowania adresami lub zbiorami adresów IP
9 Name:           python-%{module}
10 Version:        2.2.0
11 Release:        2
12 License:        Apache v2.0
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/ipaddr/
15 Source0:        https://files.pythonhosted.org/packages/source/i/ipaddr/%{module}-%{version}.tar.gz
16 # Source0-md5:  f88353e40dec06410acfa075b8209b27
17 URL:            https://github.com/google/ipaddr-py
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 BuildRequires:  python >= 2
20 BuildRequires:  python-modules >= 2
21 BuildRequires:  rpm-pythonprov
22 Requires:       python-modules
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module is useful if you need to manipulate IP addresses or sets
28 of IP addresses.
29
30 %description -l pl.UTF-8
31 Moduł języka Python do operowania adresami lub zbiorami adresów IP.
32
33 %prep
34 %setup -q -n %{module}-%{version}
35
36 %build
37 %py_build
38
39 %if %{with tests}
40 %{__python} ipaddr_test.py
41 %endif
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %py_install
47
48 %py_postclean
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %{py_sitescriptdir}/ipaddr.py[co]
56 %if "%{py_ver}" > "2.4"
57 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
58 %endif
This page took 0.611629 seconds and 3 git commands to generate.