]> git.pld-linux.org Git - SPECS.git/blob - python-importlib.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / python-importlib.spec
1 # NOTE: now it's part of python 2.7 / 3.1
2 Summary:        Backport of importlib.import_module() from Python 2.7
3 Summary(pl.UTF-8):      Backport importlib.import_module() z Pythona 2.7
4 Name:           python-importlib
5 Version:        1.0.4
6 Release:        0.1
7 License:        PSF
8 Group:          Development/Languages/Python
9 #Source0Download: https://pypi.python.org/simple/importlib/
10 Source0:        https://files.pythonhosted.org/packages/source/i/importlib/importlib-%{version}.zip
11 # Source0-md5:  5f9a0803bca7ba95f670d1464984296f
12 URL:            https://github.com/brettcannon/importlib
13 BuildRequires:  python-modules >= 1:2.3
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.714
16 BuildRequires:  unzip
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This package contains the code from importlib as found in Python 2.7.
22 It is provided so that people who wish to use
23 importlib.import_module() with a version of Python prior to 2.7 or in 3.0
24 have the function readily available. The code in no way deviates from
25 what can be found in the Python 2.7 standard library.
26
27 For documentation, see the importlib docs for Python 2.7:
28 <http://docs.python.org/2.7/library/importlib.html>.
29
30 %description -l pl.UTF-8
31 Ten pakiet zawiera kod biblioteki importlib dołączonej do Pythona 2.7.
32 Pakiet jest przeznaczony dla chcących używać funkcji
33 importlib.import_module() w Pythonie starszym niż 2.7 lub w wersji
34 3.0. Kod nie różny się niczym od tego w bibliotece standardowej
35 Pythona 2.7.
36
37 Dokumentację można znaleźć w dokumentacji biblioteki Pythona 2.7:
38 <http://docs.python.org/2.7/library/importlib.html>.
39
40 %prep
41 %setup -q -n importlib-%{version}
42
43 %build
44 %py_build
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %py_install
50
51 %py_postclean
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc README.rst
59 %if "%{py_ver}" < "2.7"
60 %{py_sitescriptdir}/importlib
61 %endif
62 %if "%{py_ver}" > "2.4"
63 %{py_sitescriptdir}/importlib-%{version}-py*.egg-info
64 %endif
This page took 0.179366 seconds and 3 git commands to generate.